Copying values of cells containing formulas

Version: / LibreOffice Community
Build ID: e1f30c802c3269a1d052614453f260e49458c82c
CPU threads: 4; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

How can I copy the values of cells rather than the formulas therein, and paste them into another document?

I used to be able to do just that – copy and paste the values into a LO Writer document or into a text editor. I’ve done it hundreds of times, relying on it for my workflow.

An example:


I would copy H16 and paste its value (here in green) into a text editor and get, as expected, ,1;<i>argumentum</i>. Now I get =CONCAT(",1;",K16) instead, and I can’t figure out why. I’ve checked the settings in Preferences but can’t find anything that mighty be the source of the change in behaviour.

Does anyone know what I have to do to get the values into another document?
copypastevalues.ods (9.1 KB)

Please upload your ODF type sample file here.

You can PASTE the values only by usage the Paste Special Unformatted text only. (The numeric values will be recognized as numbers based on the pasted alphanumerical “string” in a Writer Table. Note: the Paste function will paste the displayed decimals only.)

I’ve attached a file, but I cannot emphasise enough that the procedure described above worked perfectly well for me without any use of Paste Special.

This happens when we copy the cell content, while in edit cell mode. To test, try copying from two cells at once.
Do you have a clipboard manager installed?

EDIT: This happens with all spreadsheets?
You could try with Restart in Safe Mode (menu Help).

Thanks! No clipboard manager is installed. No Cell Edit Mode is in use. When copying two cells at once, what is pasted is still the formulas instead of the values (with a tab stop in between, here replaced by a space):

=CONCAT(",1;",K16) =CONCAT(",2;",P16)

Yes, it seems to happen with other spreadsheets (= ods files) as well. The one I worked on two months ago is now showing the same mysterious behaviour.

Edit: I’m now using the same LO version as I did back then. There must be a setting that I’ve changed. Or macOS 12.6.2 treats LO differently. (In my original post above, in the Version Information pasted from About LibreOffice, it erroneously says that I’m using macOS 10.16.)

Update: In order to find out whether copying the values from the cells in the ods file in question, and pasting them into another file, is possible on my old Mac (running 10.8.5), I tried to install LO 6.2 (= the earliest LO version using ICU regular expressions) on it but was told that I need macOS 10.9 or later. In other words, I cannot switch to another Mac to resolve the issue – I fail to find a workaround. But the matter is urgent …

FWIW, a few months ago I asked a question here when I needed the opposite of what is normal:

Ironically, the current misbehaviour – the new normal, so to speak – is in fact “the opposite” mentioned back then. I started to notice it after upgrading to macOS 12.6.2, so I’m filing a bug report.