customized style shortcut not working


I use a mac with OS 10.12.6 and Libreoffice

I’m writing a document which uses styles. I’m trying to set up a custom shortcut to switch between styles and I can’t make it work.

I’ve followed all instructions carefully, time after time, and the shortcut simply won’t work.

Can anyone help me? Thanks in advance,

This is basically what is called an “it don’t work” post.
You need to describe the specific steps you have followed.
Where are the instructions you followed?
I have several custom style shortcuts so I can confirm it does work.

Read these guidelines and ask a good question.

Okay. I set up a style called Character, that works fine.

Then in the Tools menu I clicked on “Customize…”, clicked the Keyboard tab, went to the Category column and clicked the “Styles” arrow, then clicked on the “Character,” style I had created.

Then in the “Function” column (?) I clicked “Default Style” because it seemed as good a choice as any. Then clicked on Shift-Opt-C in “Keyboard Shortcuts,” then clicked “Modify.”

That seemed to do the job. Except the shortcut doesn’t work.

I should add, I tried different key combos with no success. I should also add that I have no idea what the purpose of the “Function” column is.

Finally, much thanks in advance to anyone who can help me.

I have been having this problem since updating to Version: For years, I had a hotkey (command+E) to merge cells and it worked fine. Now, it doesn’t work. When I press it, the “Format” menu option at the top lights up but nothing happens.

I have “Record Changes” off to enable the Toolbar Button to merge cells and that works. Selecting “Format > Merge Cells > Merge Cells” works, but the hotkey no longer works and I have no idea why.

I clicked “Default Style”

Why Default? As I understand, you want to apply your own style. Or what?

I selected “Default Style” in the “Function” column because I had to select something and that seemed as good a choice as any. Other choices included “Caption Characters,” “Index Link,” and “Vertical Numbering Symbols.” I have no idea what any of those are.

In fact, I have no idea what the purpose of the “Function” column is to begin with. Why is it there?

The column is in its place, it is where you should find an item that you want to assign a shortcut to. Maybe the name of Function is not very good for this purpose. If you don’t see your style there, probably, it has not been saved properly (by the way, I’d use some explicit name for my own style, not just Character). And did you switch the selector LibreOffice/Writer to Writer?