Deleting a page

I had a page template with background template graphics+text. I unwrapped template from page for editing and finally deleted all the content in that unwrapped page. There is no content, but I cannot delete the empty page. I can’t find any single hidden character, paragraph, whatever that is still locking the page.

I found nasty way to fix this. Changed odt extension to zip and then I found in the content.xml the following:

<draw:rect text:anchor-type="page" text:anchor-page-number="1" draw:z-index="0" draw:style-name="gr1" draw:text-style-name="P21" svg:width="19.201cm" svg:height="28.54cm" svg:x="0.7cm" svg:y="0.7cm">

which after removal and reverting odt extension fixed my page.

However I wish to know how to fix this by the interface, not a hack like that.
If one would like to check, I am attaching the file - test-empty-page.odt.


There are a couple of ‘clues’ in your document. Click on the first page. The cursor is huge and at the right-hand page side. Move your mouse pointer to the header area. Move it slowly up and down over this area. It will change from a text cursor (bottom) to an arrow (top). On a blank page it should always be a text cursor. Move the pointer slowly upwards until it changes to an arrow. Click here. A large drawing object is anchored to the page. You can now delete it.

Perhaps I gave insufficient information in my original question. I am using an iMac with 10.6 OS. I am using a HP Deskjet Printer, Model 3050A. There is no text on the second page. It appears that since there once was text on the page the program thinks the page should still be there even if it is blank. Thanks for the prompt response.

Well, did you set non printable characters as visible? If so, you should see black dots instead of spaces, arrows where there are tabs and typical characters for end of paragraphs. Often, the problem you describe is caused by empty lines one forgot to delete.

Thank you for the suggestions so far, however, following your instructions reveals no visible markings of any kind on page 2. On my keyboard F10 is the Audio Mute toggle button. I have tried
several combinations of shift, control, option, and command buttons with F10 but all I get is the speakers turning off and on.

Ok, so go to View > Nonprinting characters. If it doesn’t show any nonprinting character, see this page : Nonprinting characters invisible even with "View Nonprinting Characters" checked

You might be a victim of the non-function key. Some keyboards (mostly laptops) have an extra Fn-key which works as a switch for the real function keys. try fn+ctrl+F10.

Thank you all for your help. It took a while for me with my very limited technical knowledge to figure out what you were telling me, but I finally got it. I eliminated the non-viewable characters and, “POOF” I’m back to one page. Again many, many thanks.

You’re welcome. To help other visitors to find answers to their questions, please mark my answer as correct (tick the grey check sign at the left of my answer).

None of this makes any sense to a non-techie like myself. I simply want to eliminate a document. Nowhere in this application to I find even the remotest clue on how to accomplish it. A simple targeting of the document with my mouse and depressing the delete key is sufficient on most text writing applications. Much as I would applaud a “free” competitor to Microsoft’s Word program, libreoffice is confusing, very technical (to me) and quite frustrating in my attempts to use it. I will probably remove it from my PC. I find the free Abi Word application very easy to use and I don’t have to wade through a lot of non-informative “help” files to operate it successfully.

@gpharv.tepfer, it is difficult to provide an exact answer as the problem may be caused by a variety of issues. In the case of @Norbi771 it was a hidden drawing object extending into the margin. If the text content does not run over onto a further page the usual cause is some sort of object (image, drawing, table, frame, text box, etc.) protruding into the bottom margin. It may however be caused by content specifically hidden.

Some ‘non-technical’ users will find the concept of a “hidden drawing object” not very intuitive. Of course it’s perfectly obvious to computer geeks. It just (a) doesn’t correspond to anything in real life and (b) is INVISIBLE (and there apparently is no ‘make everything invisible, visible’ command) and as a general rule - which I imagine is confirmed by hundreds of questions on this forum - having invisible things (that have effects) in a UI is confusing to people. Sometimes, even techies.

I had this same problem and finally figured it out. If getting rid of non-printing characters does not work then you probably have graphics, frames or drawing items that are on the page that are invisible for some reason (for example a line that is white on a white background). Use the Navigator (View > Navigator) and then step through each item of each type (graphics, frame, drawing item, etc) and see if there is one on the page that appears to be blank. You will know if it is there because when one of the items is selected it will highlight with the grab points in each corner and be obvious. You can then hit delete. In my case it was a drawing element. When I found it it was actually at the very bottom of the page before the blank one but I knew I had the right one because I deleted it and poof the “blank” page disappeared.

You can click left mouse to the break line at the bottom of the page and chose Delete Page Break. You can see screenshot:

KISS…This is the simple, straight forward answer for me. IT WORKS! I appreciate libreoffice and don’t want to be ugly but I spent a half hour or so setting up a login, confusion etc. After all that I came back here to promote this solution and find that I must build credibility before doing so. I can understand why filtering is necessary but if your system could lighten up on first posters the voting etc. might be more productive. A user could be revoked if making trash posts. Thanks

Deleting the header on the trailing blank page did the trick for me

Hello everyone!

I have made an account just to respont to this question.

I have tried all the advices on this page and could’t solve my problem… then I went rampage and began clicking everywhere :))

My solution is: left click in the new page then: right click → character → subscript (at the top)

Later EDIT: unfortunatelly after reopening the document the problem reappears… I simply saved my page as a PDF as a workaround

I also made an account just to respond to this response. I thought about your suggestion, and tried taking it a step farther. Doing what you said, only setting the character size to 1 instead of subscript, fixed it for me even after a few reopens.

What worked for me was;

a. position the cursor on first position on the last page.

b. right mouse-click, Alinea

c. Remove the check (see image)

Hope this works for others, it worked for me. I would also say to save your work before you start this. I made a copy of the document and tried it out on the copy first.

  1. clicked on ‘Insert’ tab at the top of the page - I was working on a Text document.
  2. dropdown menu - clicked on ‘Formatting Marks’
  3. next menu - clicked on ‘No-width NO break’
  4. go to blank page (the one with the highest number) and click on there and a thick grey vertical line appears.
  5. backspace this line until you get to the first page

All my extra pages disappeared.