Disable the new "Document in use" dialog when opening documents from a web link

Libreoffice (Flatpak install) on Ubuntu 20.04

In a flatpak install of Libreoffice 7, a “Document in use” appears whenever you open a document that is locked one or another way.

Document in use dialog

This becomes very annoying it you regularly need to view office documents from on line links. Is there a way to disable that dialog and have the link immediately opened read-only in Writer?

Previous “regular” installations behaved differently. In, regular .deb install, the same document would open immediately, with a blue message bar appearing on top"This document is open in read-only mode" appearing on top . The blue bar provides a button “Edit Document”.

image description

A flatpak install of also causes the dialog to appear.


Was your really a flatpak installation of LibreOffice?


Libreoffice 7 has introduced a new “Document in use”

That’s not new in 7.0 but a pretty old feature and a consequence of file locking. Hence you may have a remainder of an old file called .~lock.studentenlijst.5.xlsx# on your storage device. If you don’t like file locking at all (be prepared on conflicting edits, if there might be more than one instance of LibreOffice opening the files) then you may want to implement what is in answer to question How to disable file locking on linux (Ubuntu) - Permanently.

Hope that helps.

Not so. In, a document opened from the ssme weblink immediately opens, however showing a blue bar on top “This document is open in read-only mode”. The blue bar provides a button “Edit Document”. I will add this to the actual question.

Not sure whether this is correct for flatpak install: In your question Flatpak install of LO cannot connect to SQLite database you stated: Moving from the default LO version in Ubuntu 20.04 to the flatpak version (currently, hence I’d state: You compare apple and oranges (I got no flatpak installation to crosscheck).

You assume that the dialog was introduced for the flatpak version only? Could be, but that would not be the most straightforward assumption. Not impossible, though. Anyway, I also cannot currently cross-check with a that would be installed through .deb packages for now. Thank you nevertheless to pointing towards a workaround, but I am not quite inclined to disable file locking.

but I am not quite inclined to disable file locking

The reason is for both versions the same. Disable file locking (for testing purposes) and you’ll see the result. Installing 7.0.1 RC1 on Ubuntu 20.04 now, and check whether it is really a new dialog called from LibreOffice …

I was able to revert to an earlier commit of LO, flatpak, and indeed, also there the dialog appears. This is a stronger difference than I would have expected. I will add the information to the question indeed.

In the meantime I have checked LibreOffice 7.0.1 RC1 from Ubuntu “fresh” PPA and I do only see what you are used to see (blue bar with Edit Document button).