Display as Icon option missing in Libreoffice while creating OLE object

When I am creating OLE object in Libreoffice version 4.1 on ubuntu 12.04 so that I am not getting “display as icon” option.
Even When I am tried Libreoffice 4.1 in windows I also didn’t get "display as icon" option for creating OLE object.

In Libreoffice 4.1 Calc guide I found that "Under Windows, the Insert OLE Object dialog has an extra entry, Further objects.
If instead of inserting an object, you want to insert a link to an object, select the “Display As Icon option”.

I am referring this document “https://wiki.documentfoundation.org/images/4/47/CG41-CalcGuideLO.pdf
Please anybody tell me what should i do to enable this "display as Icon option in libreoffice ".

Afreen Bano

Refer this question for related bug report for non-Windows platforms.

On Window 7 it works this way.

  1. Insert > Object > OLE Object
  2. Select option “Create New” (NOT “From File”)
  3. From the list select “Further Objects”. You should get a dialog which is not a pure LO dialog, but it is in the language of your Windows operating system.
  4. In the left part of the dialog you see the option to generate a new object or to select a file. Select one.
  5. In the list you see all document types which are registered in Windows to work as OLE object. Choose the document type.

In case of “new”

  1. Check the checkbox “insert as symbol” in the right part of the dialog. Of cause you can only generate a new object, if you own the application for it. For example if you only have got Acrobat Reader, you can insert a given .pdf file as OLE object but you cannot make a new OLE object.
  2. OK. The associated application will open. Generate your document. Then somewhere in its file menu there should be an item of the kind “Finish and return to …”. Use that item.
  3. Back in LibreOffice you see the icon.

In case of “file”

  1. Use the Search button to go to the document.
  2. When the path is correct in the field, check the checkbox “as symbol”.
  3. OK. The associated application will open the file.
  4. Close the application. As long as the file is opened in that application, the icon in LibreOffice will be hatched.

The context menu of the icon, or with selected icon the menu Edit > Object, show the words (in the language of the Windows operating system) which exists for this OLE object. That are mostly “open” and when you own an suitable application “edit”.

Thanks for Reply,

While Inserting OLE Object I am getting this error message "Object Further objects could not be inserted ".

I am using Windows 7 Operatiing System.

Please Reply.

Afreen Bano

Do you try “new”, but have no suitable application?

i have tried “new” its working but icon graphic is not good and in case of “file” I am getting this error " "Object Further objects could not be inserted ".’

Any specific reason for this ??

That is likely not a problem of LibreOffice but of your system. What kind of OLE do you try to use? What application starts, when you double-click a file of that kind? What other actions are available from the context menu of such file? Do you try to use a file from network? If yes, copy it to your local PC and try again.

I have used the first “create New” option → Further Object → then " create from file browse MS word file then check it “display as icon option” then click “OK” but I am still getting same error "Object Further objects could not be inserted ". I ahve also tried with "MS Poerpoint as well as MS Excel " but getting same error message. Should I need to reinstall the Libreoffice ???

All files on my local system.
What is actaul problem have you any idea ??

Inserting an OLE means, that another program than LO will be used to open the file. Do you have such program for your MS Word file? You should try the feature with another application. You have likely Acrobat Reader installed, which will start, when you double-click a .pdf file. Try to insert such .pdf file. Which version of Windows do you have? Have you already searched, whether that version has a problem with OLE?

I have tries in another system ( window7, 64 bit) the OLE object is working fine but in XP 32 bit its not working.