Display of palette color names in the dialog


In openoffice, in the color palette dialogs (in any component that uses colors), when the mouse pointer was over a color square in the palette, the color name was displayed at the bottom of the dialog window.

In Libreoffice this gesture is gone and I could not find any mention of this topic anywhere.

How can I enable this property back? It was really useful to have the color names available when selecting.

I’m using Libreoffice Version: Build ID: Locale: en_US on a Fedora 22 installation.
My desktop system is MATE.

Any tips would be appreciated. Thanks!

I now confirmed - it has nothing to do with MATE.
I tested it on GNOME and on GNOME Classic and the problem persists.

I think that you are being too hasty…

When using the formatting Toolbar:-

for a tick (:heavy_check_mark:) next to Formatting)

…and any colour-palette dialog from that toolbar, the colour-name will be displayed as a tooltip whenever the mouse is allowed to hover for a few moments above one of the colours in the palette. Thus, the colour-name is displayed when using the palette, you simply have to wait for a few moments.

If you had said “the currently chosen colour-name is not shown at the bottom of the dialog” then I could have whole-heartedly agreed with you - a potentially useful & sadly missing hint.

UPDATED 2015-07-29:
In the light of the OP edit, dialog additions & comments + Pierre’s useful addition (new to me) I can add extra:

OpenOffice3 color-picker dialog

From recall, the dialog above is typical of OO-3 (I did not use LO in those days). I had a very similar frustration to the OP with this dialog, as it did not show the colour-name (here: “Magenta 3”) on dialogs sourced from the Formatting toolbar, but did show them on the same dialog sourced from other routes. To find the name of a chosen colour I sometimes had to frantically hunt through options & dialogs.

OpenOffice4 color-picker dialog

In contrast, this is the LO-4 dialog (currently, with:-

(menu):Tools|Options|LibreOffice|General|Extended tips selected

If only Tips is selected, then just the color-name is shown in a Tooltip (as the OO3 dialog above).
If neither Tips nor Extended tips are selected, then there are zero Tooltips.

However, in all cases with LO4 the name is NOT shown at bottom, and the only prompt to any currently-selected colour is the selected border within the palette (also selected within both dialogs above if you look carefully). That is easy to miss, and especially with LO4’s extended palette.

In addition, whilst you may think that the “Custom color…” option at the bottom is the reason, the Palette color-name has also been removed from all other dialogs. If …|General|Tips had not been selected by default, I’d have been shouting at the screen “!WHERE ARE MY COLOR-NAMES, YOU BASTARD!” within a few minutes of switching to LO4. Indeed, I think that I’d have gone back to OO as the simplest fix.

I’m with ben.shomer on this one.

If this helps then please tick the answer (:heavy_check_mark:).

Well, indeed turning off the “Extended tips” option does reveal the color name with mouseover. It is not a great substitute for the color name in the bottom bar of the dialog but much better than none.
I firmly believe it is a simple neglect in the code which should be fixed.

Thanks for your help.

So I was right, thank you for the feedback :slight_smile:

I understand your point of view on name at the bottom of the palette but it was enhanced at this place: list of recent colors that was very requested. More we can directly access the customization of colors.

Nevertheless you can submit a request enhancement since it is a regression according to you. Regards.

Thank you, but that doesn’t help.
The toolbar is there and I do get the color palette dialog.

It is really an issue of a difference between openoffice and libreoffice (or between GNOME and MATE. I can’t test that right now)

Here is how it looks like in openoffice on a Fedora 14/GNOME platform:

image description

Here is how it looks like in libreoffice on a Fedora 22/MATE platform:
image description


I think you have this “verbose” tooltip because Tools Options LibreOffice General Extended tips is checked.
If unckecked, you get the name of the selected color…