Dock navigator in writer

Hi, there
I am trying to dock the navigator pane in Writer, which floats by default over my page. Online solutions I’ve found for this involve three dots in a corner of the navigator window (which I do not have) or keyboard combinations (CTRL+SHIFT+F10, CTRL+double-clicking) which do nothing on my machine.
If I drag the pane far enough I can dock it to the edge of the screen, but this is the OS taking over to dock it. In fact it behaves like an application window, rather than a child of Writer, so I can drag it outside and position the two next to one another, but this is a palaver (often work with several documents at once).
Any ideas?

Fedora 35

CTRL+SHIFT+F10 is IMHO correct. It works for me.
If you have a laptop, you may have to press the function key.

Version: (x64) / LibreOffice Community
Build ID: 0f246aa12d0eee4a0f7adcefbf7c878fc2238db3
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL


The three dots are visible when the toolbar is Docked and Unlocked. When the toolbar is floating they are not visible.

You should get visual feedback when the window is close enough to dock, a grey outline appears, see image.

If it is the Navigator in the Sidebar then click the hamburger menu (tooltip Sidebar settings), under the X in the top right corner, and click Dock. The other Navigator toolbar (View > Navigator F5) doesn’t have the hamburger menu but will dock with outline as image above.


Thanks, Hrbrgr, for the reply, but this is not working on Fedora. Maybe it is Windows-only?

1 Like

Hi, EarnestAI
There is no visible prompt the window is ready to dock anywhere, until the OS takes over and docks it as a parent window over the top of Writer. I have, however, found a separate Navigator pane in the sidebar which seems to work the way I want (over on the right).

FYI. The hamburger menu here contains the option to UNdock (not dock), which then undocks the whole sidebar. Not sure how to dock the floating window, then. But I’ll use the one in the sidebar.
Maybe this is just a Linux thing…

Hi there, I am experiencing the same issue. Anyone found the reason for this behaviour?
I am using ubuntu 22.04 with wayland and LO

I also submitted a bug here in case you can contribute to it:


@aleix.a.m: which desktop manager are you using? This maybe related to the the widget library. I use Plasma KDE (based on Qt widgets) and everything works fine. Ubuntu uses its own desktop manager by default, inspired by GNOME, based on GTK+ widgets.

Hi, I am using gdm3, which is the default in ubuntu 22.04

Hi, I managed to solve it in my case: it was due to Wayland. I just changed to Xorg and then I could dock the navigator both by dragging and using crtl+shift+F10. Not sure if this applies to your case.