Document rendering is different between OSes

This is pretty the same problem as the one described hee: Why do writer documents open differently on different OS's?, but this question is closed.

I’ve a writer document which is rendered differently between Fedora, Windows and macOS. The fonts are the same on the 3 OSes. The exact problem is on Fedora my document is contained on a single page, but on Windows and macOS, it’s contained on 2 pages.

This is pretty annoying. Is there a way to fix this?

Just as with the question you refer to, you don’t provide a document to test, and specific details on what is different (like a side-by-side screenshot with problematic place marked); nor the specifics on LibreOffice version(s) - and OSes versions as well. And having that former question as a guideline, one could learn on the previous asker’s mistakes, and provide all required in advance… sigh.

What specific fonts are used?
Can you see differences in the spacing?
Do the lines wrap at the same place? (character spacing)
Or is there a difference in the line height or line spacing?
Or are the margins just different?
Or do you see a combination of the above?
It would be nice to compare PDFs exported from each OS.

When you say fonts are the same you mean the names that Writer shows or the existing font files in the fonts directory of every machine? Are you sure there is no LO font substitution in any of the machines?

There is nothing you can do (unless you are a very skilled programmer and can hack some system libraries) because the issue is, if I understand the description correctly (however, see Mike Kaganski’s comment), about differences in font rendering, which is the level of the operating system/graphic environment and not of an application program.

Documents commonly render differently from machine to machine, whether different versions, fonts, settings, operating systems or software.

The typical solution is to transfer in a printer-ready format such as PDF.

To make it more likely to stay on one page, you could remove some of the document content or otherwise make it smaller so that there’s more unused space at the bottom.

Another solution is to use styles that keep paragraphs together rather than hard page breaks. See the various options under Format → Paragraph → Text Flow. Then LibreOffice can automatically determine where page breaks should be and adjust for each machine. However, that doesn’t apply if you’re trying to keep everything on a single page.