Document saved in read-only when tracking changes

I have an issue with tracking changes on a document. I open a .docx received from somebody, activate “track changes” and edit it, then save it back to docx format. But re-opening the document with LO, it is marked as “read-only”, without any possibility to remove write protection. No password protection was done with track changes.

Things I tried from the web:

  • “Save a copy…” or “Save as…”. The resulting files are also read-only
  • Activate/deactivate edit mode
  • Make sure the OS permission are read-write

I checked Cannot get document off of read only mode. and Libreoffice stuck in read only mode but none helped.

Version info:

Build ID: 1:6.0.7-0ubuntu0.18.04.5
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group

Have you tried the same thing using LibreOffice’s own,native format .odt? I mean the folling procedure. Open .docx → Save as .odt (before activating “track changes”) → reopen .odt → activat tracj changes → save as .odt → reopen .odt → Save as .docx