Draw not responding when graphic images selected

I made a business card PDF graphic at Avery using template 5371. However, I have to shift the position of the PDF image to print properly. I am using Draw for this. All worked fine until I used Avery’s built-in QR code generator to insert a QR codes in the business cards.

Without the embedded QR code, the graphics select without issue and can be grouped together to move position. See attached:Essentially Card Sheet QR R3, wo QR p2.odg.

However, when I select one, any or all of the images in the attached “Essentially Card Sheet QR R3 p2.odg” file, Draw locks up indefinitely. See Essentially Card Sheet QR R3 p2.odg.

So this appears to be related to the embedded QR code.

I have no idea why this would happen.

I can move all or some images/QR codes without problem. The QR codes I had to Group as they wanted to come apart in individual rectangles, the background, curve and printing is a bitmap. Maybe the problem is in the pdf rather than the saved .odg

You can create your own QR code in Draw, Insert > Object > QR code, choose a border of 2 or 3 to be similar.

You could try, in the menu click Tools > Options > LibreOffice > View and untick OpenGL, Skia, or Vulkan depending on which is listed. See if that fixes your problem of freezing

I unticked OpenGL, but got same result: freeze up. I updated my video drivers thinking that it might have something to do with them and updated to Version, but neither resolved the issue. However, when I remove the Avery QR code graphic, there is no freeze up. So I am giving up on their graphic.

Since the file works fine on your Windows 10 OS, I am assuming this issue is just another of Windows “undocumented” glitches that just happens to manifest on my laptop. I have neither the time or inclination to delve more deeply into the matter.

But thank you very much for pointing out that Draw has its own QR code generator, which I am now using. It works perfectly with no freeze-up. This is a good enough solution for me.

I would call this issue resolved, but will leave it open for another week. If nothing else turns up, I will close the thread.

The QR codes are a bunch of 684 polygons, nothing strange seen. No issue with LibreOffice (x86); OS: Windows 6.1.