Edit mode hiding cell contents until confirmed/cancelled

Once I enter edit mode on a cell, the cell’s contents become hidden on the sheet until I confirm or cancel the changes. Everything is still there; I can technically still edit within the cell itself, copy (drag-selecting is also invisible), etc., but I have to guess what I’m actually changing because I can’t actually see its contents. Everything is still visible in the formula bar, but it’s far more convenient for my work to actually see those changes live in-document.

Is there any way to re-enable this behavior? I last updated in August, I want to say version 7.3 something, and it’s worked the way I wanted until I recently updated to version

– Update –

I’ve discovered that if I save the Calc file in certain file formats (.xlsx and .odf both seem to work, .csv does not) and then close and re-open the document, things work properly again. Seeing as it doesn’t work in a fresh file pre-saving, and restarting in safe mode doesn’t do the trick either, I’m wondering if this is a bug?

Probably related to your other post Text wrapping / line breaks not appearing in cell, text overlaps instead

Posting an example file with the problem makes it easier to investigate why.

I was told the program became unusable for some reason and got re-installed, which fixed this issue as well. Thank you!