Error message reads Install the hyphenation package for locale "zh"

Ins’t “zh” Chinese? Which means that it doesn’t have hyphenation inherently?
If there were a Chinse dictionary for the programm, is it available through extension page?

Eh, do you speak Chinese really? The language does not have a concept of hyphenation, as I know.

is it available through extension page?

This is a bad question. Go to the page and search.

@gabix, I am afraid you misunderstood the question. It is not the issue of whether Chinese has the concept of hyphenation or not. It is about the error message that LibreOffice prompted to users which is meaningless.

The message appears when the paragraph (style) format implies automatic hyphenation, but no hyphenation module is installed for a particular language. That’s OK. However, this particular case probably deserves a report at Bugzilla.

I read and write Chinese and I have the same problem. When I open a document with Chinese characters (I am editing one that is .docx and changing to another format is not an option) I have the same problem.

I am using Libreoffice on Ubuntu 20.04. Getting this error is not the only problem. All formatting of the text is gone and it is not possible to underline characters, only italic and bold are possible.

Does anyone have an idea of how to fix this problem?

After having the same problem and having typesetting problems at the same time I tried to see what I could maybe add as an extension. I found nothing.
So far my only solution is to copy the text into a new document, but it has to copied as unformatted text otherwise the problem will still be there. When I save the new file and open it the error message is gone and I can typeset the characters. I know it is not a nice solution, but at least it sort of solves the problem. (I am sure that if someone edits the document with some other program the problem will come back).

I got the same error, but for «qlt», in my case. Reading your comment @Molbo

“So far my only solution is to copy the text into a new document, but it has to copied as unformatted text”

Made me think… if this is a hyphenation problem, that is solved in a new document, this must mean the language it is written in (or it is supposed to be! written in) is indeed supported by my system. I checked my system’s hyphenation support (in my case, Arch Linux. All of those packages from the official repos):

  • hyphen (general library for hyphenation)
  • hyphen-en (English hyphenation rules)
  • hyphen-es (Spanish hyphenation rules)

So, if the document was supposed to be in Spanish and, in fact, if I write a new document I get no errors, I did a very simple thing: tools > language > entire document > Spanish.

And the error was gone.

So, to sum up:

  1. Check/install hyphenation support for the desired language.
  2. Make sure that document is, indeed, all in that language.

Could this be helpful?