"Evenly distribute contents to all columns" doesn't consistently work

I have several pages, all with the same layout: A single title line at the top, one column that spans the page. Then two columns of body text. In all cases, the two columns are marked “Evenly distribute contents to all columns.” But sometimes it works and sometimes it doesn’t. It seems to have something to do with the length of the content, but I can’t figure out a pattern.

I’d like all of these pages to have their contents evenly distributed. How can I accomplish this?

Here is a zoomed out view of several example pages:

The original ODT document: columns.odt

I’m using LibreOffice, Build ID 1:5.1.4-0ubuntu1, CPU Threads 4, OS Version Linux 4.4, UI Render: default,
Locale en-US (en_US.UTF-8)


Edit style Heading 3Text Flow tab▸untick Keep with next paragraph


In my experience, this woudn’t be the cause of the problem, unless the style for the text paragraphs also have “keep with next” or “do not split” flags checked. It is usual to have heading styles with the special flags, but they must be reset for body text.

Hi @ajlittoz - I was surprised too. It may not be the cause… but whatever it is, it’s the solution, unless you have another one?


It shouldn’t have worked, but it did. It’s frustrating to not know why, but for this immediate project, it’ll do.