Excessive Loading Time in Calc for ods file

Whenever I load calc, I am double-clicking on the file I want to open - see attached. In a previous version of LibreOffice, it was taking 45 seconds (of blank screen) before the spreadsheet was shown. I found a comment somewhere that someone said the front end was trying to communicate with a printer that was off-line. So I changed the default printer from my local printer to “Microsoft save as pdf.” Suddenly the load time was reduced to 5 sec. I was able to live with that.

But in the past week or two, whenever I open the file again, it now takes 30-38 sec to load and display the spread sheet. I tried many things to no avail, including safe mode. I converted the file (save-as) to xlsx, and that file loads immediately without any delay. But when converted back to ods, it again takes 37 sec. to load. There is no change to this behavior if I first load LibreOffice and load the file from there.

So what’s the difference between an ods and an xlsx file that Calc is taking so long to load an ods? Is there any solution to this problem?
Video List 220501.ods (213.7 KB)

I’m using Win 10 and the latest LO version (7.2.7) x64. I have a QC i5 with 16G mem with 500G SSD.

To be clear, can you repeat this behavior with any ODS file?

Your file (213kB), double clicked, takes me 3 seconds to open.


With me:

Version: 7.3.4.2 (x64) / LibreOffice Community
Build ID: 728fec16bd5f605073805c3c9e7c4212a0120dc5
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL


The PC is 11 years old!
Prozessor Intel(R) Core™ i7-2600 CPU @ 3.40GHz 3.40 GHz
Installierter RAM 16,0 GB
Systemtyp 64-Bit-Betriebssystem, x64-basierter Prozessor
Stift- und Toucheingabe Unterstützung für Stifteingabe


First steps

Check step 4 in the Link.

In case printer settings would be still a problem, you could try to uncheck Tools → Options → Load/Save → General, Load printer settings with the document.

4 Likes

@joshua4 :
Yes, it does (with other ods files). One more thing that might help, if a Calc file is already open, and I open a 2nd file, it doesn’t get the delay (the 2nd file opens immediately). So the delay happens only if there is not a Calc file already open, and happens every time.

If I load Calc with nothing, the blank sheet comes up immediately, no delay. It’s only after a file has been saved as ods that it happens. I just did that, merely putting “x” in A1 and saving the file, and the delay happens after closing the file and reopening.

One more data point: I had 3 Calc files open, and I opened a 4th, and noticed that this time, there was about a 3 second delay (blank, grey screen with “L” at top left), before the spreadsheet was displayed. In that spreadsheet there are only 4 sheets with info in rows and columns, no calculations.

Hrbrgr: I have no idea what your options/settings are. Are you starting from LibreOffice already open? Did you enable open LO on startup? Do you have any Calc files already open? If I have other Calc files open, I don’t get the delay.

@erAck , unchecking “Load printer settings” had no effect.

@Hrbrgr:
There are no calculations in the sheet. That option says “open CL is not used.”
I tried resetting the profile by both the help wizard and manual, and neither worked.

“1. if you have specified a printer in your document that is switched off, delays may also occur. However, I do not know if this is LO version dependent” (7.1.8 very slow - #4 by Hrbrgr).

“I tried @ajlittoz’s suggestion, specifically Tools > Options > LibreOffice Writer > Print > Paper tray from printer settings. It was on, and I clicked it off. Since then, with the printer off, every spreadsheet I try opens immediately” (Calc: Simple .ODS file loads slowly under LO 7, .XLSX fast - #24 by djc).

@LeroyG , I don’t see an option to eliminate specifying a printer. Like I said, it is set to “Microsoft print as pdf.” Also, the options path you show doesn’t exist in my options menu. I already know that a specified printer turned off will incur delay. That is not the issue at hand.

LibreOffice Writer exists only if you have a Writer document open, and be it only an empty new document.

@erAck : ok, I found it. However, “Paper tray from printer settings” was not enabled.