Export PDF - default to same directory as ODT/DOC file

There is a discussion of this issue about OpenOffice.

When I click the PDF tool to Export Directly as PDF, the default directory is wherever I last exported a PDF. This is unhelpful for me, I often forget to change the directory and PDF files end up in hard-to-find directories. I store files in folders by subject not by file format. I almost always want to store the PDF in the same directory where the editable ODT or DOC file resides. How can I make this the default?

did you try the solution by B Marcelly ?
( menu Tools:Options:LibreOffice:General:Open/Save Dialogs:Use LibreOffice Dialogs )

Feel free to suggest this as an improvement to LO (click on Help | Feedback and put it in Bugzilla as a suggested new feature. I agree, it would be nice to have to options: static (as it is now), relative (like you suggest), and sticky (what was used last).

(Can’t seem to edit my comment above, so here is the revision) …That’s Help Send Feedback Create Bug Report New LibreOffice Sevirty: Enhancement

LO Export PDF defaults to the last folder used by Export PDF. This is an extremely useful feature for those who collect all PDFs of LO .odt documents in a separate folder.

Just select the folder you want once and LO will always use it!

@JohnHa: “… is an extremely useful feature for those who collect all PDFs of LO .odt documents in a separate folder.”
Doubtlessly. However, the OP wanted it extremely useful the way he likes it - for probably good reasons.
I myself, on the other hand, virtually never use the ‘directly’ icons at all, but prefer to spend the few seconds I may need in addition to quit a dialog. In my feeling it helps a bit to avoid waste of much more time in the few cases I hit the wrong icon, or a case requires different handling, while the next case may require the original defauilt again.

Concerning the OQ I sketched a solution independent of dialog styles or in another obscure way of ticklish things probably subject to changes without notion.

If interested you may study this attached example.

===Edit1 2019-01-06 12:00 CET===
Two amendments:
-1- The macro contained in the attachment is inappropriately assigned to the button event ‘Mouse button pressed’. It should be assigned to ‘Execute action’.
-2- To prepare for actual use, you need to move the macro to a module of your local standard Library. You also cannot reasonably assign it to a button conveniently then, but have to use some additional toolbar control (icon/text) or additional menu entry to which you can assign the macro. Use >Tools>Options>Customise for this.

Just guessing. OP = Original Poster, i.e. the person? OQ = Original Question ask? Before I start using these, I wanted to be sure I knew what they meant. (Sure would be neat if Ask.LibreOffice would turn these and other jargon into a fly up definition box when you mouse over them.)

I’m German and I have not at hand a reliable list of expressions and abbreviations of the kind. I just took the risk to use these because I found them myself repeatedly in rather unmistakable situations. “Ugly but short.” In addition I would assume that the difference is not made concerning “thing vs person” but Post(er) vs. Question(er).

There is a behaviour difference between Linux and Windows (I use both).
In Linux, when exporting, the location starts from the default path for documents (I guess Tools > Options > LibreOffice > Paths > My Documents).
In Windows, it starts from the last location used for exporting a pdf … which also annoys me a lot.

I have the same problem,
I need to save files of the same project together not to mixt up projects because they have the same extension (PDF) .
In previous versions I selected menu:Tools:Options:LibreOffice:General:Open/Save Dialogs:Use LibreOffice Dialogs
but there is no more an option ‘Open/Save Dialogs’ under ’ Tools:Options:LibreOffice:General’
How can we work this out? For me this means I need to move each file I save!! is very inconvenient.

This is not an answer. Use the “add a comment” tool if you want to contribute to an ongoing discussion.
The post is also placed into an inapt thread because the respective set of options changed since the original question was posted as you stated yourself.
It’s clearly a case where a new question is indicated if you don’t find a younger thread better matching your case.
BTW: The solution based on user code I demonstrated in the attachment to my answer surely still is working. However, I chose the wrong mouse event 2.5 years ago: Assign the macro to ‘Execute action’ instead of 'Mose button pressed.

I found the link below works a treat. It solved the same problem as you have BobStein. Truth, is was buried deep in the bowels of the software so the average Joe wouldn’t of found it. Anyway, I hope this solves your plight my friend.

Thanks for posting this.

In LibreOffice 5 the solution was what @librebel pointed out. menu Tools:Options:LibreOffice:General:Open/Save Dialogs:Use LibreOffice Dialogs

But in LibreOffice 6, this is the solution.