Export PDF to same folder where .odt resides

I had to reinstall LibreOffice (Version x64) on Windows 10. Now exporting doesn’t work the way it used to, or I installed a wrong version.

To export, I click File > Export > choose “PDF…” as the File format > click “Export” button
The “File format” is always pre-set at “EPUB Document (.epub)”
Only after changing it to “PDF- Portable Document Format (.pdf)” will the exported PDF go to the same folder as the ODT.
I never had to change the file format before.

I also used to be able to do File > Export As > Export Directly as PDF (default file format as “PDF- Portable Document Format (.pdf)”), and the exported file would end up next to the .ODT file. It’s no longer working that way. When I click the Export button, it will open to a nested folder and will keep opening to nested folders until there are no more folders.

So 2 things are not working as they did before.

At one time, I was told to change this setting to “false” and then exporting would work:
Tools > Options > LibreOffice > Advanced > Open Expert Configuration
Search for: UseSystemFileDialog
Found under: org.openoffice.Office.Common > Misc
Double click or Edit to change “true” to “false”
Click OK

Anyone have any ideas for how to fix these 2 problems?

A similar directory problem is that I today opened a .wpd file using LibreOffice. Then I edited the text and wanted to save it. A screen indicated that I was to give the file a new name with .odt extension. So I typed a new file name with .odt extension. When I saved it, the file wanted to save inside a nested folder and not inside the original folder where the .wpd was stored.

This other thread seems like a similar problem: Serious issue with filenames on export to pdf?