Extra Line of Space at the Bottom of Pages in Writer

Hello Everyone,

When I’m using LibreOffice Writer to write a document with 1" margins there’s an extra line of space at the bottom of page, making my bottom margin seem greater than 1", which I’d like to fill with text, as sending such a document to a potential publisher may look unprofessional.

My workaround has been to change the bottom margin from 1" to .99", which results in this extra line being filled with text. Changing any/all of the Options under Text Flow in Paragraph Style hasn’t helped. Nothing I’ve done with changing the Text Body style has helped either.

I’d like to know if anyone has a solution which will allow me to keep my bottom margin at 1" while also filling the odd gap with text.

I’ve searched for solutions online and haven’t found anything which solves this issue for me, and I’m sorry if what I’m asking is obvious or stupid.

Here’s an example with formatting marks on:

Build ID: 1:6.4.7-0ubuntu0.20.04.6
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Random Text.odt (9.4 KB)

You did not display the Formatting Marks (CTRL+F10 shortcut). In your case the widow and/or orphan control could be a reason. See: Text Flow

Nothing can de deduced from your screenshot. Edit your question to attach a sample file.

I’ve uploaded an example and added a screenshot with formatting marks on.

It looks as though there is not quite enough room for an extra line of text. There could be a number of reasons for this including the font sizes of your headings and body text, the line spacing, and the space above or below paragraphs. The space between the last line of text and the bottom margin may also vary if the page ends with the last line of a paragraph. Widow and orphan control settings can also influence the distance between the last line of text and the bottom margin.

You are submitting a manuscript, not a highly designed final publication. In other words: Don’t worry about such space variations. Concentrate on your content and writing style.


Writer has no provision to “justify vertically” text in a page. Your problem is a matter of integer arithmetic. Your margins define the height of the usable area. Within this area, you can layout some number of lines and paragraphs.

Within a paragraph, lines are counted for their line height (can be set in paragraph Indents & Spacing). Add to it spacing above and below defined in the same style tab. Sum up over all paragraphs and you get the effectively used height. What is left is the difference between the used height and the page text area. Thus, all your pages will end at the same position. The remaining blank partial line height will not be noticeable.

Assuming you have not enabled orphan and widow control, nor other text flow properties like Keep with next paragraph or Don’t split paragraph, the bottom empty space should be smaller than a line height.

This is unavoidable.

I mentioned that Writer has no vertical justification. Consider that such a justification could result in undesirable visual effect. Lines in facing pages would not be aligned (supposing that all paragraph styles have basically “comparable” settings in font size, line height and spacing).

If you want to mitigate the disparity between pages, you can enable registering in the page style and align the paragraph styles on the page grid (a check box in Indents & Spacing). Registering is enabled by Use page line-spacing in the Page tab of a page style and you designate a reference paragraph style to define the grid.

Note: registering is a typography technical word which was not understood by the majority of users. So its name was changed in the 7.x releases to reference page line-spacing. Since you’re still under 6.4.7, you might still find word register true or registering in the style definition dialogs.

Remark: your sample file has received direct formatting to eliminate Spacing below defined by Text Body paragraph style.