Font names corrupted

Libre Office Version:
Iinux Mint 20.3

I installed several Irish fonts. Many of them show up in the font box as corrupted.
For example Urchló GC shows up as ⁄rchlÛ GC and there are worse examples.
I have dozens of fonts and this makes particular ones difficult to find.
My keyboard is a Logitech Cordless Desktop and I have tried English and Irish regions.
The font names show up OK in Linux font viewer.

Font name comes from an attribute table in the font file. You didn’t tell where you downloaded it from. Be aware that old fonts may predate the Unicode era and the name may be encoded as ISO-8859-x or, worse, some CP-999 DOS/Windows character set.

Your first task is to check the origin of the font files. Then you may try to have a look at these with FontForge (if can interpret what’s reported).

Thanks. They are Unicode letters. OpenType layout, TrueType outline. The example I mentioned was produced in 2010.
It shows up OK in Windows LibreOffice.

This is not a solution to your question. You should have used “Comment” to report feedback. So, please, retype it as a comment and delete your non-answer for community benefit.

Where can I download the font to make a try here (Fedora Linux 36) to see if this an OS-related problem?

I went to web site Úrchló GC and downloaded the OTF implementation of Úrchló GC - leagan (version) 13.00 dated 2022. It seems to render the name of the font and the text correctly although the accented characters lose their accent in the name of the font, Urchlo GC but that appears to be intentional.

Version: (x64) / LibreOffice Community
Build ID: f85e47c08ddd19c015c0114a68350214f7066f5a
CPU threads: 8; OS: Windows 10.0 Build 22000; UI render: Skia/Raster; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: threaded

Thanks. They are Unicode letters. OpenType layout, TrueType outline. The example I mentioned was produced in 2010.
It shows up OK in Windows LibreOffice.

So does the 2022 version work OK?

Yes it does! Thank you. I only just downloaded it this morning.

Now I’m trying to find Bunchlo Arsa GC, which has, but the link has been removed. I emailed them about it but no reply. I can’t find it anywhere on the web either.
It is IMHO the nicest Irish font, though Gadelica is quite close but has issues with the ponc (the dot above consonants).

If you know the site then it is easy, in any search engine, like Duck Duck Go, just enter the name of the font and the site name like this Bunchlo Arsa GC The site: confines the search to the designated site. That search term appears to find other fonts too. I see that Bunchlo Arsa GC has an updated 2022 version.

That’s a useful search tip. But there was no Bunchlo Arsa on my results, only Bunchlo GC and four variants.

Sorry, I misread the result. Maybe it has not been updated and has been dropped.

Eventually I got a reply from Gaelchlo.
The Bunchlo GC files have variants built-in somehow. To select them you have to use Styles and you have to enter the reference number for the variant after the font name in Styles.
It’s very inconvenient.

There are 3 other styles in the font. You can select some text and click Format > Character. In the dialogue that opens click the Features button to select the style. I don’t know which is the one you want but lets assume it is Stylistic Set02. If you OK out of the dialogues you will see the font name is now appended with :ss02

You have probably found the above and found the variant you want.

To use the variant on a regular basis you would want to make a template with the paragraph styles set to the variant.
Create a new document, it doesn’t need to have any text in it. The easiest way to set the default font is to modify the Default Paragraph style.
Right click Default Paragraph Style at the top of the Styles Sidebar (Ctrl+F5) and select Modify. Select the tab labelled Font, select the Bunchlo GC font and click the Features button. Select the variant, e.g. Stylistic set02 and OK out.

As you can see most of the styles are now modified to use that variant of the Bunchlo GC font. The exception are the Heading styles

You can set that font variant or another font by modifying the Heading style is a similar manner.

Click File > Templates > Save as Template. You can make it the default template so every new document is based on it, or you can have it as a template accessible from File > Templates > Manage Templates (Ctrl+Shift+N).

Many thanks, I’ll work my way through that. that.
I take it there is no easy way you can ‘extract’ the style and make it into a separate .otf?
It would be so much easier if it was a separate font like it used to be.

It is harder to explain than to do. I don’t know what stylistic set was the required one. I chose Stylistic set2 because it had more differences. Here is a document in which I set the Default Paragraph Style to Bunchlo GC:ss02 and Heading to Bunchlo Dubh GC:ss02
BunchloFontStylistic2ForTemplate.odt (9.1 KB)

The Writer Guide has more information on using styles, it can be downloaded from English documentation | LibreOffice Documentation - LibreOffice User Guides

You’re right, it’s not hard to do at all, just that I haven’t used templates before.
The styleistic set3 has thrown up an error, though not a serious one. The ampersand sign & in irish script is the “Tironean 7”, (like the number 7 extending below the baseline). The symbol shown is Hex26 vs Hex 204A I’m being unreasonably picky of course - as befits someone who is fanatical about a dying language! I will tell Gaelchlo about it, and maybe learn a bit about font editing.
Bunchló Arsa is largely unrecognisable to those accustomed to Roman scripts, especially the r and s.

There is free font editing / creation software called Font Forge. I think there is a bit of a steep learning curve to use it. It is outside the parameters of this forum but there would be one for Font Forge I guess.

As there is an existing place in Unicode for the Tironian ⁊, even in Arial, then it is unlikely that Gaelchlo would change it. The easiest way to get around that issue is to make that substitution in Tools > AutoCorrect > AutoCorrect Options > Replace and create a new rule that & should be replaced by in Gaelic language.