Format of citations changed after re-opening libreoffice writer

I’m trying to use the bibliography and it seems to be working fine until I close Writer then re-open it.

For my short name I enter, (as an example) Smith, 2015. When I re-open the document instead of seeing [Smith, 2015] I see

[CITATION “Smith 2015”].

I wonder why it is changing?

Furthermore, when I update the index the “Entries structure and format” has changed so the listing is:

CITATION “Smith, 2015”: , The Title of the Article,

Once again the word “citation” has appeared and additional fields I set up such as ISBN and URL are lost.

The problem seems somewhat similar to the one raised in this thread. But I tried the workaround in that thread - ie setting type = 0 = article - but the issue remains.

I guess it is probably not relevant, but in the Bibliography database view the field name for the ‘Short name’ shows as ‘Short name’ in the record view but ‘identifier’ in the view of the .odb table - is something perhaps not referencing properly?


… and you use format ODT for your document?

Thank you for your comment - it’s actually the solution as I was saving it to docx as that is the required finished format for this piece of work (unfortunately). I will mark it as the solution if you want to provide your comment as an answer. Saving it as odt now and it works fine.

As an aside - I will probably add another comment in a couple of days as I need to find a way of submitting it in docx without messing up the bibliography, but as I don’t have MS Word will need to look on someone else’s machine. If there is a ‘dynamic’ link between the document and the Base table, I’m also now wondering how it will work when I put the document somewhere else that does not have the odb file in the same place.

The problem is using DOCX format. Bibliography data isn’t preserved correctly when exporting to DOCX. The solution is using ODT (FTR: this is tdf#105367).

Thank you also for the bug reference. Comments ‘19-21’ say the the release LibreOffice has fixed the issue. So I installed (previously had from Kubuntu repository). Saving my odt as docx then re-opening it, the bibliography entry issue was indeed fixed but the index did not display properly. When I removed all the entries and deleted the index, then started again, it worked.

Those comments don’t state that the issue is fixed; only that display of entries is fixed now :slight_smile: