Libreoffice Write Bibliography does not display as intended

Good evening everyone,
I am writing my thesis and currently i am facing trouble with the bibliography system.I am editing the index (bibliography as shown in pic au,ti,jo,ye,vo,(nu),:pa,us (where us is user defined and it has stored the doi numbers) and have save it as type “user defined 1

”. but whatever i do i get a display as if it was the predefined type “article”the 2nd pic
any ideas?
Thanks in advance

Looks like there’s something broken in selecting the bibliographic format (article, book, conf. proceeding) but I’m presently on an old version of LO. However, if I manually tweak the entry template, it works. To make sure, what happens if you right-click in your bibliography and Update Index/Table?

I checked with and same behaviour. Could other gurus explain what the Type selection is supposed to do? I clicked and double-clicked on suggestions and this does not seem to change the entry structure.

well actually nothing happens.
However i think i have found a way around the problem. It seems that (in my case) the only changes it accepts/fulfils are those made on the type: article selection. I have made all the changes there. However i will need to change manually some entries as i am using not only journal research papers as bibliography but also some books and online web material.
Is there an easy way to export the bibliography database to zotero for future usage?
Kind regards,
Sofopoulos M

The bibliography is a Base database file (extension .odb). You’ll find it in the user config directory. Its path is given by Tools>Options, LibreOffice>Paths. The root part ends at /user/. Add database to this stem to get …/user/database/. The bibliography is made of several files and one /biblio/ subdirectory. I don’t know how you can handle this, maybe an export using Base.

You can apply character styles to any field in the “structure” line: just click in the button representing the element and pick an appropriate character style from the “Character style” drop-down menu. For the paragraph as a whole, in the Styles tab you can select a paragraph style for any entry in the index and that paragraph style will provide the underlining format for that entry.

No, i was not writing about that. My problem is that i want the bibliography to be presented like: authors,title,year,volume,number,pages,doi (like the 1st picture) instead no-mater what I do I get a presentation like the second photo (that is like authors,title,year) which does not suit me.
Any ideas?

Can you upload a sample document showing the problem?

A workaround

the problem. It seems that (in my case) the only changes it accepts/fulfils are those made on the type: article selection. I have made all the changes there and got this result:image description

If its a bug I hope it will be fixed properly in future relases.

Kind regards,

Sofopoulos M

And who of developers knows about this bug, for it to be fixed in future releases? Please mention the number of the bug you filed to the bug tracker. This would help anyone interested to track the progress of the issue. Thanks.