Funzione se multipla

Buongiorno a tutti. Per favore vome si inserisce una funzione se multipla in una sola cella? Mi spiego. Avrei bisogno di queste condizioni:
se il numero della cella F2 è inferiore a 50 scrivi 0
se il numero della cella F2 è compreso tra 49,99 e 99,99 scrivi 25
se il numero della cella F2 è compreso tra 100 e 149,99 scrivi 50
se il numero della cella F2 è superiore a 150 scrivi 75

Non riesco a cavarne fuori la formula, potreste aiutarmi per favore, grazie.

it: =PIÙ.SE(A1<50;0;E(A1>=50;A1<100);25;E(A1>=100;A1<150);50;A1>=150;75)

en: =IFS(A1<50;0;AND(A1>=50;A1<100);25;AND(A1>=100;A1<150);50;A1>=150;75)

LibreOffice aiuto su PIÙ.SE.

EDIT:
it: =IFS(VAL.TESTO(A1);"testo";E(A1>=0;A1<50);0;E(A1>=50;A1<100);25;E(A1>=100;A1<150);50;A1>=150;75)

en: =IFS(ISTEXT(A1);"testo";AND(A1>=0;A1<50);0;AND(A1>=50;A1<100);25;AND(A1>=100;A1<150);50;A1>=150;75)

I valori inferiori a 0 risulteranno in #N/A.

EDIT: Ho cambiato AND in E nella formula in italiano. Scusa, stavo modificando la formula a mano.

Già in LibreOffice c’è la funzione PIÙ.SE…non ci sono ancora abituato :wink:

Ciao! Supponendo il dato in A1, prova
=SE(A1<50;0;SE(E(A1>=50;A1<100);25;SE(E(A1>=100;A1<150);50;75)))
Oppure con una tabellina d’appoggio, dove nella prima colonna c’è il valore minimo da analizzare e nella seconda il risultato da ottenere, potresti usare
=CERCA.VERT(A1;G2:H5;2)
La seconda soluzione secondo me è più versatile, in quanto se hai molte più condizioni da verificare, basta allungare il range della tabella nella formula, mentre usando il SE diventerebbe una formula lunghissima.
Ti allego un esempio,dove poter fare prove e confrontare i due metodi.
Funzione SE multipla…ods (9.2 KB)
Ti allego anche il testo della risposta, perchè il traduttore del forum distorce qualche termine.
Risposta Funzione SE multipla.odt (11.4 KB)

1 Like