Heading font doesn't always change

Using LO Version (x64) on Windows 10

I edited Heading 1 in Styles (F11) to be 12 font bold. When I select one word text and click Heading 1, the font incorrectly changed to 10 font regular.

I cleared formatting on the one word and tried the above steps again and still did not get 12 font bold when clicking Heading 1. Cleared formatting again, clicked Heading 1, and then the word correctly changed to 12 font bold.

In other cases when trying to create a heading for one word, several sentences below also had the Heading 1 attributes applied. After much trial and error, I figured out creating a hard return after the heading word, clearing formatting on everything below that word, I was then able to apply the Heading 1 format.

If there is a better way to apply a heading without all the extra clicking and clearing formatting, please let me know.

Maybe I didn’t make it clear, but I am using the heading for paragraphs so that it appears in a Table of Contents.

Here’s a sample where I tried to change the heading of “Milk” to Heading 1, but all the text underneath also changed to Heading 1.


Heading 1 is a paragraph style. If you need to change one word style you must use Character Styles.


Can you share a file with a neutral example (using “bla, bla”, or non sense text). Use the paper clip button below your question.

Why do you use line breaks instead of paragraph break?

To see what I mean, enable View>Formatting Marks. The difference between your line terminators becomes obvious.

Shift+Enter (sometimes called “soft” line break) is not a paragraph delimiter. It is used in special circumstances to cause line wrap without leaving the current paragraph. This is what happens in your “Milk” paragraph.

Newbies erroneously think that Shift+Enter has the same effect as Enter (closing the current paragraph and creating a new one) with the added artefact of deleting spacing between both. This is wrong. You have no extra spacing because you remain in the same paragraph.

If you need to eliminate vertical spacing, modify the paragraph styles or create dedicated ones.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

When I copy stuff off a website, I then click my PureText icon to remove formatting. I guess it’s not removing the Shift+Enter line break (which looks like an arrow pointing to the left when viewed in View > Formatting Marks).

Sometimes I (incorrectly) do hit Shift+Enter when just Enter makes the next line go further down than I want.

Thanks for the info. I now know what I should and should not do!

I wish I knew how you get the little red words in boxes in your reply. But that’s a different question.

“little red words in boxes”: (grave accent) text (grave accent), or select text and click in the 101 010 button just up your comment.

@oconomowoc: Shift+Enter is not considered formatting but a structuring delimiter; this is why it is not removed.