How can I get spell check to work for French content (in an English install / locale)?

Everything is underline in red. No french words isn’t giving a mistake

I have this :

I don’t know what to do or check

Which operating system and LO version are you using? Is the LO version provided via PPA?

Sorry if this seems basic to you, no offence intended.

Did you forget to give a specific style to your French paragraphs? When you define a paragraph style, you can choose the base language in the font tab.

Similarly, if you need to “quote” (cite) only a few words within an English paragraph, you can define a character style with a specific language attribute in the font tab. For example, when I want to intentionally “escape” spell checking for procedure or variable names in technical papers, I use a “NoLang” style with language set to “None” (and font set to a monospace family to emphasize the non-literary context of the word).

The answer here provides a clear check-list of what is required under Tools > Options… > Language Settings > Writing Aids.

I did that. it thinks it’s in french, but it’s like if the dictionary is empty