How can I move tables in Writer?

1) My workaround

Add an empty paragraph before the table > select both > Ctrl+X > Ctrl+V.

2) Documentation

Writer Guide, Published 16 February 2012. Based on LibreOffice 3.4.5.

Chapter 9: Working with Tables

Moving a table (page 24)

To move a table from one part of a document to another part:

  1. Click anywhere in the table.

  2. From the main menu, choose Table > Select > Table.

  3. Press Ctrl+X or click the Cut icon in the Standard toolbar. (This step removes the contents of the cells but leaves the empty cells, which must be removed in step 6.)

  4. Move the cursor to the target position and click on it to fix the insertion point.

  5. Press Ctrl+V or click the Paste icon in the Standard toolbar. (This pastes the cells and their contents and formatting.)

  6. Return to the original table, click somewhere in it and then choose Table > Delete > Table from the main menu.

3) Bug Report
Bug 40893 - Drag and drop complete TABLE (contents) leaves empty table behind

Status: RESOLVED NOTABUG REOPENED (see @Pedro1’s comment below)

("…feel free to submit an enhancement request if you can provide a
conclusive concept…")

@manj_k Thanks for your answer!! But I think the Documentation’s method for “moving” a table is so cumbersome, and does not allow drag and drop, should count as a big bug, not an “enhancement” request!

It is not a BIG bug but it is inconsistent with what you expect from other word processors AND it is inconsistent with MOVING other objects within LibreOffice. I have REOPENED the Bug.

In my opinion, it would be better to treat this problem as a request for enhancement.
Related sample ‘Please treat tables as object’ →
[Reported: 2004-06-27 · OOo 1.1.1 ] :wink:

I realize this is a really old post, but I was wondering if there was any new developments with moving tables. Moving a table by clicking and dragging still has the same bug as described above. Cut and Paste method isn’t great as you can’t have tables side by side. The frame method described below works, but slows the software down when there are too many frames in the document.

Any other workarounds?

There are several bugs in the move table code (at least under Windows and apparently on a Mac too). When you select a table (the easiest way to select a whole table is to click on any cell and then use the menu Table, Select, Table) the cursor should change to the Move cursor. It doesn’t. You still get the Edit cursor but you can use it to click and drag the table somewhere else. The Table with contents will be moved but a copy of the Table borders will remain in the original position (which doesn’t make any sense since you wanted to MOVE the table…)
So your only option is to delete the Table borders that were left on the original position.

@Pedro1 Wow this is a pretty big bug!! Can you tell me how to get the Edit cursor? I can’t find it. Thanks!

@avamk The Edit cursor is the large I with a top and bottom bar. I think it’s the only cursor available :slight_smile:

@Pedro1 is this has been reported as a bug could you post the corresponding URL ?

@magicfab I think it has but I really can’t find it at bugzilla. Sorry!

A more elegant way to move a table freely around a page is to create a Frame (Insert, Frame) and then click inside (you may need to click outside in a writable area and then click inside) to Insert a Table.

The Frame is now moveable by changing the Anchor options.

Ho thanks bro…this is it yar… i mean it’s not only about moving a table around, if you want to type beside a table also no other option works…great

frame movement is great but there are frame wrap issues

Unfortunately, I’ve had problems with this method as well. If you have a whole bunch of frames in a single document, the software slows to a crawl. It becomes extremely aggravating to work with. I have a pretty beastly computer, too, so my hardware isn’t the issue.

I just ran across this tonight migrating an important file from Word to Writer.

No useful way to do simple table moves and and easily adjust text flows.

In my opinion this is a major Writer deficiency. I really do not give a damn about the niceties of Bugs vs Enhancements.

I am in the process of migrating from MS Office to Libre Office.
I have managed to do do that for Excel (Calc is pretty good - took a bit of work, but I am there).

My attempts to move from MS Word to Writer have been frustrating to useless. So I keep using Word.
Handling of table and graphic management, is so lame, that it makes Writer almost useless to me.
In Word I could grab a Table, position it where I wanted it, and then easily manage the text flow around it. Have not found a way to do that with Writer.


A little addition for whoever needs it:
If the table is at the beginning of an odt, and you need to move it down, you need to make an empty paragraph before it. Go to the top of the table and click alt return.
Blessings, Klaus

Just as big a pain in the ass in Linux version - c’mon guys this is supposed to be EASIER to use than M Word, not HARDER!

go to the beginning of the first cell. press alt+enter. the table will be shifted to the next page. right click inside the table. go to Table>Text Flow>Text Flow. Uncheck Break. and done. Or just play around with that Break. The radio button of Page should be unchecked.

There is no Table->“Text Flow” in v4.2.4.

i’m having the exact same problem. it doesn’t matter if you call it an enhancement or a bug, one is a euphemism, and the other a dysphemism. the bottom line is that i can’t use libre write because moving a table to where it belongs is such a basic task, that if it doesn’t work, it’s broken.
sure you could put in the x and y coordinates of the table under manual format, but really ?
i bought a $2500 bicycle, but without the $10 chain, it’s worthless. yes it will roll downhill, and it looks really good, but it’s useless as a mode of transportation.
please let me know when this problem is fixed so i can patch my libre office.