How can I stop the dialog to select a language for content copied&pasted from a browser in Calc from popping up?


I have a very annoying behaviour with my Calc app (LibreOffice 3.5 inside a OpenSuse 12.1) when I paste different data from a web page into any cell in my Calc file (a native generated .ODS file !)

Exactly here what happens:
in my ods file I need to paste various data taken from some web page (numbers, as well as texts and URLs (web addresses) !).
When I click on paste, Calc always asks me this:
“Select the language to use for import” inside a popup window titled “Import options”; There are 2 radio-buttons “Automatic (which is auto-selected”) and “Custom” and 3 buttons “OK”, “Cancel” and “Help” … There’s also an optional option for “Detect special numbers such as dates” (not selected).

I always HAVE to click on OK in order to paste the value !

This is immensly annoying, and worst, I don;t find where is thsi behaviour located, in order to change it into NOT asking such thing !

As far as I can find out, my browser (Firefox 19.0) has the default language setting (which is English USA) and my Calc document is the same (english USA) … so I don’t get WHY did it asks me for a language since both are the same. Regional settings with my OS (as mentioned above, OpenSUSE Linux, version 12.1) is also English USA … Also keyboard layout is set to EN (US) …

Please … can anyone shed some light into this thing ?
I really need to change this and get rid of this questioning (and thus boost my productivity :smiley: with my copy/paste activity …). And maybe you understand the frustration of getting this popup every time I paste a new value…


This is very annoying - same problem on Fedora 24 with Version:
Build ID:

Still present 4 years later. There must be a reason this thing pops up, but I haven’t found it, or how to turn it off.

Here’s the bug, and it’s not even assigned after 5 years:

Hi guys pleaase press F2 key on cell then paste.

If any other option please informe me same

Yes, seems double-click does the same thing - basically make sure a cursor appears in the box, instead of seeing the entire box selected with a border.

solved the issues. Tools > AutoImput , it must be disabled

Take a look if some of the options in “Menu/Edit/Paste special” works better for you.

solved the issues. Tools > AutoImput , it must be disabled

Thax, already tried that … Paste special did work without this annoying question, BUT … is nonetheless an extra work to do: too many clicks in order to just paste a value … almost same time to do it like that (paste special), as it is in the first place, with that question … not very much helpful

solved the issues. Tools > AutoImput , it must be disabled

Okay … to make things worse …

I tried same actions described above (in my first post) with Libreoffice 4.0 on a Windows system (windows 7). I call it “worse” since on windows this behaviour DOES NOT happen !!!
Now, before I go crazy, please, doesn’t anyone in the Libreoffice stuff know anything about this ?!?!?
WHY the same actions made on a Windows system does not happen exactly the same on my Linux system ??? (that’s one of the strengths of this office package, right ? to be able to reproduce the same actions no matter the operating system where it lands … or it isn’t ??? )
How come making copy/paste from a web page in LO (4.0, but I’m sure this is true on LO 3.5 …) in Windows behaves totally different than the same thing done in Linux ???
This really drives me crazy (and mostly because I’m sure this is a Libreoffice specific issue, it does not have anything to do with any settings in my Linux … nor does it with the browser I’m using – the same thing happens when copying those values from Google Chrome, or Opera…)

solved the issues. Tools > AutoImput , it must be disabled

To access directly to paste special, two ways:
Shortcut: Ctrl+Shift+V
Clicking in the icon right arrow:
image description

Err… sorry, CTRL+SHIFT+V takes the thin up to another level of annoyance :-))
So, if I do this, I got now another window (with the title “Paste special” and wants me to give an answer to this question: “Selection” (and have to choose from “unformatted text” and “HTML” !!!
Well … I know I’m using a package prepared by the OpenSUSE team, and not the package downloaded dorectly from libreoffice site … but do you think that they messed it up so bad as to behave this way ? I don’t think so … I’d rather suspect it’s something wrong with the way Libreoffice (Calc) treats this issue (pasting values from a web page into on of it’s cells…)

As for the other option … when clicking simply on the plain icon, I got the window I was writing in the first post. If I click on that little right arrow, I have to choose fro those 2 option mentioned above …
Still no much of a help in doing the paste desired.
So I miss my “beloved” middle-click that simply pastes the copied values in my Linux… Why did Libreoffice mess it up so bad ?

solved the issues. Tools > AutoImput , it must be disabled

Well … things are even worse than I first estimated :slight_smile:
The same thing happens when I try to copy than paste some (any) values from any mail I have in my Thunderbird client !!! (let’s say this would be some sort of a okay behaviour, as thunderbird is another internet related software…)
But … the same happens when I simply copy the name of some file on my PC (inside the “dolphin” file manager) and then paste that value into Calc’s cells !!!

AND … to make it even worse … if I try same thing with the Opera browser … gues what !! it works OK !!!

Now … I’m really going crazy, because I just don’t understand this program’s behaviour …

No one with any clue about it ?

solved the issues. Tools > AutoImput , it must be disabled

Hello, people of the past! Still broken on v4.2.8.2 on Ubuntu 14.04.2 LTS.

Hey, but you get what you pay for …

solved the issues. Tools > AutoImput , it must be disabled