How come an button assigned macro does not do all the actions it shoud do ?

It’s in a LO Calc file. I’ve recorded a macro and saved it inside the standard module of the file. It does simple things : in the first column, the police is set in bold, italic, green on an orange background. Then the cursor goes to the fifth column and write “COMMAND” in the cell, and the goes back to the first column, but in the following line.

I can assigne a keyboard shortcut to the macro, and everything is fine. I can create a new button in a new toolboard, and everything is fine. But if I create a form button and assigne the macro to this button, not all the macro is executed. In fact the font isn’t set in bold and italic, but the colors are right, and the word COMMAND is in fact witten where it should.

Is that normal or am I doing something wrong ?

Oh, I’ve already ask this question last year ! Sorry.

But there is still no answer?

it’s an old issue that the ‘focus’ being set on a button impacts macro run, description, ‘not yet solved’ and trick to circumvent see: