How do I change background border colour

How do I change background frame colour. NOT the page itself but the border of the page that is currently white, I want to contrast the white page with a black background.


Hi, Thanks for your responses. I don’t think I framed my question properly.
What I want to do is change the background colour NOT of the page, but of the page background. At the moment I have a white background and white page, thus it is very bright screen and no differentiation between page and the ‘wall area’
Imagine a piece of white paper and a black table, I want to put my paper on the table. So it is the area outside of the page I want to change to black.

See attached 2 documents!

The thickness of a regular border is limited, so I used a frame (area = black) with a white rectangle in it. Sent both to background, anchored frame in header so that next page continues the layout… Sometimes the frame and the draw object “catch” the cursor and only after hitting the ESC bar you can insert some text…


A better approach to a very broad page border could be a background image as a page property. At the moment I’m afraid that there are some glitches for a neat embedding of an image that can spread the entire page area… Check the file!


My workaround is slightly different from @Grantler’s.

It starts from the same remark that border width is limited to 9pt. Moreover, trying to set a border in a page style will have adverse effects on header and footer should you need them.

I enable header in the used page style.

In the header I attach two nested frames.

The first frame is as large as the page area. Its position is Center to Entire page both vertically and horizontally. Its Area colour is set to black.

The second frame is as large as the page “useable” area, i.e. margins removed. Its is also centered both horizontally and vertically. This is compatible only with equal top/bottom and left/right margins. If they are not pairwise equal, you should position this frame relative to the top left corner. Its Area colour is white.

Both Wrap properties are set to Through, In background and Allow overlap.

As @Grantler mentions it, you need to hit Esc to leave frame edit mode to return to “text edit” mode.

See WidePageBorder.odt.


In case you only want to contrast the useful part of the page on screen, go to Tools>Options, LibreOffice>Applications Colors. The settings you are interested in are probably Document background and Apllication background.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.


Tools / Options / LibreOffice / Application Colors

Custom Collors / General / Application background

Thank you Sir, this did exactly what I needed and I appreciate your excellent instructions. If you are ever in London, I buy you a beer! :slight_smile:

Okay, thanks, I’m writing it down in my calendar. Hug.