How do I Disable Wrap Text in Calc?

How do I switch OFF wrap text in Calc?
I had a CSV of contacts. I saved as .ods.
After making some changes I noticed Calc had expanded some of the row heights to allow the cell to wrap text.
I didn’t want this. I just want the unformatted text that was in the csv!

There is a button to Wrap Text but it’s not a toggle button to not wrap text.
In Format Cells I can un-check “Wrap text automatically” but it doesn’t unwrap them.

I can hover the mouse between row numbers at left of screen and click but not move the cursor to see what height other columns are set to but it doesn’t show the actual height it shows the height it would be based on where the mouse is hovering.

If I click to see optimal height for a row it shows 0.53 cm but if I apply that to one or all rows it makes them all that high so I don’t see the actual difference between Optimal Height and Row Height.

If I click to set Row Height it says 0.45 cm.

I can select all rows and set them to a height I choose (e.g. 0.45 cm) but I want to set it to adjust to the text not an arbitrary number I pick based on the current font height which I might change later.

If I double click the row height for one of the rows that is too tall it does nothing.

What is the simple answer to this common situation please?
I want to set all rows to not wrap text and be the appropriate height for the text.

I am not pasting text - I simply opened an unformatted CSV and saved as .ods.
2017 How to disable automatic text wrap in calc when pasting?

2014 How to disable automatic text wrap in calc when pasting (LO 4.2)

All sorts of stuff gets wrapped up in csv, if selecting the cells and unticking Wrap text leaves the text wrapped then maybe there are line breaks in the .csv.

Click Ctrl+H to open the Find and Replace dialogue.

  • In Find enter \n
  • In Replace enter a space
  • Tick box Regular expressions
  • Click Replace All

tdf#159938 ?