How do I get Base to work under Lubuntu 16.04?

I have a fresh installation of Lubuntu 16.04 (up-to-date). I then installed LibreOffice (after downloading LibreOffice_6.0.2_Linux_x86_deb.tar.gz and extracting) using sudo dpkg -i *.deb

All works well EXCEPT Base.

  1. I open LibreOffice and click on Base Database.
  2. I create a new registered database.
  3. When I save the database, Libreoffice closes.
  4. I then reopen LibreOffice and open my new database for editing.
  5. It opens with the Forms icon highlighted.
  6. I click on the Tables icon to edit this database and LibreOffice closes.

I tried opening a different .obd file that I created in MS Windows. The same problem occurred when I clicked on the Tables icon.

I raised this matter in the Ubuntu forum and was told that LibreOffice Base is now not compatible with Ubuntu. Is that true?


Have you installed either Oracle JRE or Open-JDK (must be 32-bit because of the LO you have chosen - why not 64-bit LO)? Have heard nothing about LO Base not being compatible in Ubuntu. Works fine under all distros I have tried.

I have the following installed:





Do I still need Oracle JRE or Open-JDK?

I am not rich. My PC is over 10 years old, second hand and a 32-bit system. CPU is 1.6Hz with 1GB of RAM.


Not familiar with ‘default-jre’ and have never used ‘openjdk-8-jre’ in 32-bit mode. I have used Oracle JRE in 32-bit and it worked with Base on Ubuntu 32-bit OS.

First check settings in LO. See my answer this post → Problem with Java. If Java cannot be located, install 32-bit JRE from Oracle & re-check settings.

If this answers your question please tick the :heavy_check_mark: (upper left area of answer). It helps others to know there was an accepted answer.

In LO, Options>LibreOffice>Advanced shows a checked “Use a Java runtime environment” and that Java runtime environments (JRE) already installed is Oracle Corporation version 1.8.0_151

OK. Found an old post of mine working with an older Ubuntu 32-bit version and LO 32-bit. Turns out that on that test jre1.8.0_101 would not work. Downloaded jre-7u80-linux-i586.tar.gz from Oracle and everything worked fine. Created .odb, table, form - all worked.

If you install the v7 JRE, make sure in options it is the one selected.

It looks like Java 7 is no longer available for download. I have done numerous searches and have not been able to find a reliable site that offers Java 7 download.

From the Java web site:

"Where can I get Java 7 downloads?

July 2015: Java 7 are no longer available to the public. Oracle offers updates to Java 7 only for customers who have purchased Java support or have Oracle products that require Java 7."

Are there any other suggestion?

That’s not accurate. Have found easily on internet search → Java SE 7 Archive Downloads. Just accept the license agreement & download.

Thank you for the link. I downloaded jre-7u80-linux-i586.tar.gz and extracted. Then in LO Tools>Options>Advanced I added the path to JRE 1.7.0_80 and set it as the JRE to use. Restarted LO, however the problem persisted.

I have found a work-around to me problem here. In a nutshell, I add the kernel parameter “stack_guard_gap=1” the my grub file. I am not sure what this parameter means or does, however it works for me.

Now all of LO is working as expected (I hope).