LibreOffice Base crashes on 32bit Linux

I launch LibreOffice base, create a new base, use the default (HSQLDB), just click next, OK, chose a file name, click OK, and it crashes.

"soffice.bin crashed with SIGSEGV in " “stack_expand_to()” or ""JNI_CreateJavaVM()

It is a 32bit machine, It crashes with Ubuntu 16.04 LTS as well as the newest 17.04, fully updated. (Tried OpenJDK 8.131 and Oracle Java 8.144 and tried updating LO to latest version 5.4). I tried on a physical machine and on another one in VirtualBox.

It does not crash using a 64bit install. 32bits used to wor in 2016, before some Ubuntu updates in 16.04 LTS.

On 16.04 LTS there is typically: LibreOffice 5.1.6~rc2 / kernel 4.10.0 / OpenJDK 1.8.0_131

Any hint??

Another post for the same issue.

Mint 18.3 32bit & Libreoffice 6.3. Base crashes when trying to create or connect to a table. Switched to Opensource JRE from Oracle JRE. Problem solved!

I finally found some info. Issue started mid June 2017.

  • Yes LibreOffice Base does not work on a 32 bit Linux machine
  • It should be fixed with a new kernel release (hopefully)
  • It is a change in the kernel (security fix) that affected Java that is required for LibreOffice Base
  • Neither Ubuntu or LibreOffice or OpenJDK can fix this kernel issue (OK, maybe OpenJDK could also fix it)
  • There IS a workaround (tested on 16.04 and 17.04): “Add kernel parameter stack_guard_gap=1”

Here is how to add kernel parameter: grub2 - How do I add a kernel boot parameter? - Ask Ubuntu . You should remove this parameter when the new kernel solve the issue (test), because I guess is it less secure without stack_guard …


This kernel issue also affects LO Writer on 32-bit Linux if Java is used, and likely in any other LO applications, at least on Fedora 25. For example, if Java is enabled, going to Tools > Macros > Run Macro… causes Writer to crash. Fortunately, the workaround above works in this case as well.

I read many bug report what related this bug , but not clear this problems for me, because we build and use LibreOffice on 32 bit blackPanther OS with 4.9.20 and 4.14.4 kernel between, WITHOUT any kernel parameter and JRE is enabled, and LibreOffice working fine! Not have a freezes or crashes…

Around after LibreOffice 5.5 releases we have get many problem after build. Example: can’t save documents to odf formats (rebuild with newest boost, etc solved this problem), and after 6.1 crashes writer if java is enabled with same (4.9.20 - 4.14.4) kernels ?!

We tired debugging with --strace/–backtrace but did not bring really result because we got java and memory errors.