How do i open a pdf file in draw so the Greek unicode is not scrambled?

I can edit most pdf files in draw, but Greek unicode text is opened or imported scrambled.
Maybe I should export the pdf file differently in the first place when I created it.

Are you sure to have the font installed?

Example source file containing Greek filler unicode text: greek.odt

If I generate a PDF from this file (LO v3.5.7.2) I can open the corresponding PDF without issue in LO Draw (v3.5.7.2 or v4.0.1.2). As mario’s comment indicates, this is likely a font issue. It may also be related to PDF generation settings.