How do I shift the page number to the bottom of the page inside the footer?


this is my first post. I need to shift the page number inside the footer 1cm from the bottom of the page. Right now is 2cm according to the bottom margin of the page. I tried to press Enter inside the footer but it didn’t work. I know Writer uses styles but I was unable to shift the page number field down the footer 1cm for the bottom of the page.

image description
image description

is it possible? Many thanks!

@Giutor: you changed the question title with “[Solved]” prefix but you didn’t check the answer you considered the solution.

This site is not a forum and uses a different signaling. You must click on one of the gray check mark to flag the question with a green “OK” icon on the home page. Otherwise, it remains “Unanswered” in the underlying database.

Hi, I apologize, I deleted the word “SOLVED”. Where can I find the icon? I see only “edit retag flag offensive close delete”. Many thanks.

At top left of answers, you have a “value score” between top upvote and bottom downvote arrows. Below, there is a gray tick mark. Click only once on the tick mark of the answer you consider best. Do this only once even if seemingly nothing happens. It may sometimes take a bit long to turn green but it will. If you click a second time, you cancel it (toggling action).

Many thanks for your patience!

You’re welcome.

You already give yourself the answer, set the lower margin to 1 cm.


Insert a text frame (Insert → Frame Frame interactive or Frame ...).

Anchor it to the footer and position it where it should go.


Thank you so much for your reply but it doesn’t solve my issue as I need to maintain 2cm from the bottom edge. The page number should be inside the 2cm but 1cm from the lower edge of the page. I hope I made it clear. Thanks!

The Writer-fashion way of doing this is with styles. In Writer, margins are no-print area and should remain so.

There are two points to address:

  • page geometry
  • alignment of footer

##Page geometry

From your specification your bottom margin is in fact 1 cm high and you want your footer to be 1 cm high whatever is in the footer area.

Format>Page Style to access the page parameters (or select the **page style(s) you are using)

  • in Page tab, set your bottom margin to 1cm
  • in Footer tab, uncheck both Use dynamic spacing and AutoFit height; set Height to 1cm

This takes care of your geometry.

##Footer alignment

Footer is formatted with Footer paragraph style (what a surprise!). Modify this style properties.

  • F11 or Format Manage Styles to make visible the side style pane if not already there
  • right-click on Footer and Modify
  • in Indents & Spacing tab, set Spacing Above paragraph: to 0.5 cm (this value must be adjusted according to the font face and size used for the footer)

This solution may seem more tedious than the one proposed by @PKG but it guarantees that any field insertion will show what you expect. When using frames, fields may show anomalies due to the order in which frames are scanned relative to the main text flow (the page content). Note however frames are safe with page number but this is no longer the case if you want to repeat chapter name or other content related information.

As a general rule, avoid frames when they are not necessary. They have an impact on performance, stability, reliability and compatibility (should you want to export as .doc(x)).

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

Thank you, that helped!