How do I stop Writer from uncontrolled scrolling when I scroll with the mouse?

I am editing a long document – about 300 pages. When I scroll up or down, the program often takes over and continues scrolling on its own, far past my goal. This happens whether I use the scroll bar or the cursor. It takes a good while to stop, and I don’t like the waste of my time. How can I stop this unwanted behavior?

I have the same problem, just not in LO Writer.
Sometimes FireFox browser goes crazy this way.

Make sure the error is not based in your mouse/mouse driver.

“Once you eliminate the impossible,
whatever remains, no matter how
improbable, must be the truth.”

It also happens in LO calc on Windows. For some reason, the behaviour changed in 4.x from the way other scroll bars work in Windows. The way it works now is that the scroll bar represents the position in the document. If you click near the bottom, LO goes to near the bottom of the document. Click near the top, LO moves to near the top of the document. This drives me crazy. The only way I’ve found of controlling what I see is to either use the PAGE-UP or PAGE-DOWN keys to move a single page either way or to grab hold of the position marker in the scroll bar and drag it up or down a little way. See also Clicking vertical scroll bar in Writer jumps to position, not 1 page.

I wish there was a way of configuring the scroll bar so that a click below the position marker moves the position down one screen and a click above the position marker moves up one screen.

FWIW OpenOffice does not behave this way: it behaves like other Windows apps do scrolling a single page up or down depending on what side of the slider you click.

@mikekaganski: I tried to reproduce this with a spreadsheet of 100 rows. It behaved like other Windows apps. Extending to 200 rows still behaved like that. Extending to 513 rows, calc started to behave randomly: sometimes like Windows apps, sometimes moving multiple pages, sometimes moving to the position where I clicked. The spreadsheet I created: A1 value “Date”, A2 value “=today()”, A3 =A2+1, A4=A3+1 and so on. I’ve submitted bug 113567

Under Linux/KDE, some KDE developer decided on its own to change scroll bar definition to adopt this behaviour. He also removed the small scroll arrows at both ends and it is impossible to configure things in the OS to revert to previous style (even through init scripts). He might have good development reasons to do so but this decision is particularly user-unfriendly and badly impacts user experience (in all applications).

I cannot reproduce the said behavior with on Win10. So I suppose it’s not something universal with LO. It would help if @andy17 filed a bug report.

@ajlittoz: is there a reference to this? could you please post a link to bug #?

(In reply to edit with reproducing details:)

Then please do file a bug report at bug tracker with detailed instructions how to reproduce, which OS and LO versions you use, etc. Without bug reports, no one will look at AskLibO site to pick a bug and fix it.

(I still cannot reproduce, even after extending your recipe up to 2154-09-22, i.e. to 50 000 rows.)

I’ve raised the bug report (113567: as per the bug report it sometimes works as normal Windows apps, sometimes multiple pages, sometimes moves the slider to the position in the spreadsheet. It seems to be random.

Fine, thanks.

In the meantime, you could test (available on LibreOffice download page under pre-releases) to see if it makes any difference for you (there was some calc scrolling performance fix; however I cannot be sure it relates to your problem, because I couldn’t repro both with and

@mikekaganski: this regression was already mentioned in this thread in March 2016.

I can’t retrieve the KDE 5 post reporting the change in scroll bars but here are some references to the problem: Mozilla, Fedora

(continued) It may also be related to the desktop graphics themes. Recent ones do not allow any longer to customize scrollbars, essentially because the scrollbar “driver” no longer retrieves custom configuration.

But all I tested display the scrollbar the same with same behaviour. The cause may be deeply rooted in low levels of the OS UI.

@ajlittoz: of course, the OP’s problem is absolutely different (it’s some inconsistent operation on Windows, where the arrows are present, and also clicking on bars sometimes operate properly, sometimes not). OP has filed the report, and hopefully will be reproduced and fixed. But is there a corresponding report (in our bug tracker) to the Linux problem?

@mikekaganski: I haven’t filed a report in the bug tracker because I suspect it’s not LO fault but OS. Latest changes (with switch from X11 to Wayland, and also changes in desktop themes) have created havoc. Misbehaviour happens in practically all applications both under KDE and Gnome desktops. But I haven’t had time (and patience) to thoroughly investigate. Sometimes developers make decision without taking into account YMMV, not anticipating consequences :frowning: