How do you change the Help font from "Segoe UI" to a serif font?

Ubuntu 20.04
LibreOffice 7.1

The font in the Help pages content is Segoe UI, which is an italic font. It is really annoying to read help content when it is all in italic.

I tried the suggestions in However, if you select some text in the Help contents and paste elsewhere it is automatically changed to the default font.

I opened the /usr/share/libreoffice/help/default.css file. I guessed at the font by progressively applying the fonts listed in the font-family attribute to a test string until I got italic after applying Segoe UI.

In default.css, I removed all mention of Segoe UI, and have replaced all sans font references in the font-family attribute with serif references (including the generic serif reference).

After closing LibreOffice Writer and relaunching it, the Help opens with Segoe UI. Oddly enough, when I open a random *.html help file in BlueGriffon, an html editor, the text is displayed in ‘Palatino’ (URW-P052) as desired.

So somewhere there is a setting that overrides default.css but where is it? Any ideas how to fix this?

which is an italic font.

My system doesn’t show an italic font and I never saw offline help being completely italic (at least since it is shown by a browser)

Segoe UI is not an italic font (comes in regular, B, I, BI); it is a Microsoft system font so I would not expect it to be on your system.

Maybe you don’t have any of the suggested fonts (or ones your system says is a substitute) for displaying help so your system has found a font that it thinks is the closest.

The list I see in default.css is “Segoe UI”, Roboto, Ubuntu, Cantarell, “Noto Sans”, “DejaVu Sans”, “Lucida Grande”, “Helvetica Neue”, Helvetica, Arial, sans-serif, FreeSerif, NanumGothic, “Noto Sans Tibetan”, Taprom;

I discovered a dirty fix for this.

  1. In any LO app, go to Tools > Options > LibreOffice > Fonts.

  2. In the Replacement Table pane, set [x] Apply replacement table.

  3. Type Segoe UI (or whatever) in the Font field and Palatino (or whatever) in the Replacement

  4. Click the green tick (check) and then click Okay.

I would appreciate if anyone can tell me a clean fix.

Earnest AI: Y es, that’s what was in my original default.css file. But I edited the attribute to {font-family: P052, FreeSerif, system-ui, serif; } and still got fake Segoe UI until I made the dirty fix. (I haven’t elevated this or the previous comment to an Answer because I would like a more elegant Answer!)

Do you have any of the fonts listed? I would have thought you should have Noto Sans, Roboto or Ubuntu at least, so do they work in a document or are the fonts damaged?

I don’t see the first part of the question, that would:

  1. State how LibreOffice and its help were installed in the first place (snap? PPA? TDF packages? self-built? with specific versions of related packages);
  2. State how the help is started (likely Help|LibreOffice Help?);
  3. Show the screenshot of the problem.