How to change language in whole document?

Hello,

I use localized version of latest Libreoffice (Polish), but I’m working on English document. So far I easily switched to English spell checking. However I cannot force Libreoffice to use English across whole document. For example, when I add caption to table I get:

Tabela 1: Table description

instead

Table 1: Table description

It always use Polish translation for captions of table, image, etc.

See also → How do I get translated caption categories?

For me the bottom answer by @webwurst was the most clear and correct answer. I created an account just to be able to upvote, but sadly this is not possible with <5 reputation. I am on LO Writer v6.0.7.3

Try to change “local Settings” and/or “Userinterface” to english. You find it in Tools->Options, Language Settings->Languages.

You can change the language of the current document via Tools / Options / Language Settings / Default languages for documents. Choose your desired language and check For the current document only.

This is the correct answer!

Why can’t I upvote this with less than 5 points reputation. I signed up just to vote this up, but ridiculously I can’t.

It works, thanks.

I found this that was helpful to me:
https://help.libreoffice.org/6.4/en-GB/text/shared/guide/language_select.html?&DbPAR=WRITER&System=UNIX

Are you using the multi-language version?
I assume that this could help you. I install always the English-US version (=multi-language version) and select the 4 languages I am using and never had the problem you mentioned.

When you install the multi-language version for the first time, I recommend a customized solution. This allows you to select the language you want to use. When you upgrade, the selection is done the same way automatically.

Please look at the answers in

It seems we have a bug here. May I suggest you get in touch with the person who raised the question behind above link and optimize the information for the bug report.