Working with different language documents

I am working on both English and Hungarian language documents.
I don’t need spell checking, but things like captions should work differently.
Eg. in English I need : “Figure 1.”
in Hungarian I need : “1. ábra” for example.

Now as far as I’ve understood from the help and previous posts in some topics, if I change the document language, then Writer should automatically change both the number-text order and the language of the caption word.

However, for me it does not.

(Btw, using the Tools>Options>Languages> for this document only method for changing the doc language is pretty cumbersome. Especially when there is a menu option Tools>Language>For all text as well, which of course still doesn’t do anything.)

Now, if I change LO interface language to English, it will give me English style captions. If I change to Hungarian interface, it will give me Hungarian style captions. Changing the interface language (and restarting) every time I edit a different document is not the preferred way for me.
Changing the text in the caption menu works, but I also need to enter the caption menu and change the order as well. And this doesn’t seem to be the best solution either, when it should work without all this hassle just by simply changing the document language.

(Btw I tried Apache OpenOffice as well - it was worse, I entered a number like 1.2 in a table cell and it automatically converted to a date. There I also couldn’t change the number format (decimal dot or comma) to change automatically with document language. It’s still a problem with LO, but here at least the table cell is not set up to auto-convert.)

I’ve seen these topics:

(only lets two links shown here)

It seem others had the same problem several years ago, and the answers given seem to have not worked for some and still don’t work for me. (Probably there were different problems for those who made it work, or they didn’t understand the problem correctly).

Currently using LO

No. Where in documentation is that mentioned? We need to correct that incorrect claim.

It does. If it doesn’t for you, it’s a bug. Well … What specifically do you expect?

You may have two separate profiles for LibreOffice; each may be configured to use different UI language. You may create separate shortcuts calling LibreOffice with those user profiles; you may even have these two instances running in parallel.

Maybe I was mistaken and it was only mentioned in the forum posts.
But all three threads I found about it (btw only found using google,not the forums’ search)
have been closed and I didn’t find out the reason for this. In one of them they did flag it as solved, but as it turns out it was not solved for many of us.

What I wanted to know in the first place, is officially how should it work at all?
And then, whether it’s really a problem for me only…
It’s something that has been mentioned almost ten years ago and involves a lot of people I assume. So I thought there should be some way of doing this, I mean an easy way. (There are reasons I want to switch from MS Office and wanting to do things the hard way or encountering same bugs is not among them).

I’d also like to know if there is a difference between the two ways of selecting a document’s language.

Thanks for the tip about the profiles. I do want to simply open LO by clicking on the document in totalcommander, so then I think this wouldn’t work that way.

IMHO, linking caption to UI language is a design bug. Insert>Caption should take into account document language at least. Ideally, it should be the “local” language setting, but as Insert>Caption will create a new paragraph, it can’t use any inheritance" because it can’t determine reliable to which element the caption will be attached (a frame has no language attribute; a caption may be positioned above or below other elements; …).

I frequently write documents in language other than UI. It is really an annoyance to have to patch the captions. If anything else, document language is the one for Default Paragraph Style unless there is another way to determine it.

Not sure to have understood your “two ways”.

UI language is the one selected for the menus and toolbars. It is not supposed to interfere with text.
Language for document (in Tools>Options, Language Settings>Languages) advertises Writer about the language for document text so that spell/grammar checking, hyphenation, … are handled correctly.

Captioning is done with macros (or equivalent, I am no developer) and I suspect language is probed in a too simplistic manner, assuming that UI language and document language are the same.

By two ways I mean:

  • Tools->Language->For all text
  • Tools->Options->Language->

IE both change document language.
Except both don’t do a thing. (Besides spell checking, which I don’t need and therefore didn’t check at all.)

I think they do exactly the same thing through two different menu items. Anyway, the result is rigorously the same.

Then it’s kind of funny why the in other topics they advocated the longer method :smiley:

I also don’t know, if it’s really a bug, why the other threads were closed and some marked as solved…

Do you think it’s worth getting a bug ticket ? (Someone must have done it already, it’s been known for a decade) . (Do I really need a new registration to a new site for bug report? As far as I’ve seen…)

I’ll file a bug as soon as I have time because this behaviour is also a pain for me.

Bug report tdf#151020


I looked at the bug report the first time I posted, and it looked a bit menacing. (And have to register again for some site, as if this one wasn’t enough…)
Was going to revisit it, but didn’t make up my mind yet…