How to change the installation language

when i install the program it doesnt use english which is the language version I installed it uses the country where i live. how do i get it to install in english?

…except the method no longer works. For me anyway.,

[If OS Windows]

Have a look at → Installation of LibreOffice on Windows.

A. Language of LibreOffice user interface

1. Installation Wizard

Select "Setup Type"

☉ Custom

(Dialog Box #3)

Select "Additional user interface languages"

(Dialog Box #4)

2. LibreOffice

Menu Tools → Options → Language Settings → Languages → Language of User interface

Select "English (USA)"

Restart LibreOffice

B. Language of Installation Wizard

Paragraph "Localized installer":

[…] you can force LibreOffice Windows installer to start in any language with msiexec command from the command line. For example

"msiexec /i LibO_3.5.3_Win_x86_install_multi.msi TRANSFORMS=:1084"

will start the installer of LibreOffice 3.5.3 in Scottish Gaelic […]

For English (UK): TRANSFORMS=:2057

(More… → Locale IDs Assigned by Microsoft)

Edit 2013-10-31


See also: fdo#51038 · fdo#44915 (Status: RESOLVED FIXED) · fdo#58145 (Status: RESOLVED FIXED)

See also:

Bug 51038 - Error while trying to launch English LibreOffice installer (Status: NEW)

Bug 63827 - Default Installer Language (Status: NEW)

AskLibO: “Windows installer is not localized” - bug (51038) still exists?

See also → libreoffice-l10n · Localisation gone wild

See also: Bug 82184 - Improve installation process for non en-US locales · Status: NEW

Not sure if this is the best place for my question. Is it possible for future development of Libre office to simply the language selection. Open office you can choose the language of installation as a tick a box. I have seen Libre office on a computer in English and like it. I just lack the skill to understand this solution with the command line and hope with a future edition of Libre Office this could be resolved as I am using a Chinese computer and would like Libre Office in English.


See also: Simplifying the setting for installation language

I just want it to stay on the language I told it to use. The styles and spell checker keeps changing from English UK to None. So no spell checking, no auto-correct … and so on.

Sick of having to go change styles and paragraphs and documents back to my chosen language all the time.

BTW - always get English South Africa too - it this because I use a Ubuntu based distro?

@donrob – That’s another topic. Please file a new question.

You may also have a look at → When I’m starting program it is no language to check spelling.