How to delete unwanted blank pages at the end of a .doc file

I have a number of doc files which have one to thirty-ish blank pages at the end. I can do a “return” at the end of the text, and the excess pages disappear. If I save the file and re-open it, the blank pages are back. I have tried numerous ways to eliminate the blank pages permanently, none of which work.

I’ll try to attach a sample of the problem. Thanks for anyone’s help!
----new--------------------------------------
I added a screen shot to show the blank page.

I am using LO ver 5.0.3.2 on Linux Mint 17.3. If a later version of LO is known to eliminate the problem, I will change to that. I’m reluctant to change only “on the chance” it will.

I am a semi-retired consultant; my clients all use MS Word and Excel. I have no choice in using the same formats as they. While I may agree with the benefits of open source, for my continued income, I must stay with doc and xls.

Since several folks have openned the sample file I sent and do not have the excess blank pages which I do (as shown in the attached screen shot). I suspect a later version would help. Any suggestions as which – also, does anyone have any insights to the ppa versions?

Thanks!

Joe Henley

Joe HenleyHenley-test-2.docScreenshot from 2019-02-19 18:52:53.png

Two ways to provide a sample: either insert a link (= the “world” icon in the toolbar) to some free upload service (pointing directly to the file) or attach (= the paper clip icon in the toolbar) it to your question, meaning you must edit it. The second method requires more karma point. Tell me which one you prefer (for the second one, I’ll upvote your question to grant you karma).

OK, sample file is attached. It has one excess blank page at the end which I cannot get rid of.
Thanks for your help!
Joe Henley

No excess page in 6.2.1.1 on Win10.

Have you looked at How can I delete 7 blank pages in Writer document?

One suggestion is to always save the file as an .odt after you have removed the extra pages. There may be some problem with your .doc file which helps cause the problem. Word treats pages in a different way to libo writer.

How are you paginating your document? Are you inserting the page breaks yourself ? What version of LibO are you using? Are you creating the files on LibO or have you imported an existing word document? The more information you give, the more we can try to help.

Using LO 6.0.7.3 under Linux Fedora and KDE desktop.

Your file has no extra page. But apparently, you space vertically with empty paragraphs (only a CR). You can see that if you enable View>Formatting marks.

The second page contains 4 significant lines and ends with 4 empty pars. Margins in my Default Style page are set at 2.0cm. If they differ from yours, text composition may vary, e.g. flushing some text on the second page (while you have none) whereas you have only the empty lines, giving the illusion of a spurious page.

For me, everything is OK in your file.

Recommendations:

  • spacing between paragraphs should always be adjusted in the Indent & spacing tab of the paragraph style dialog. This also contributes to consistency throughout the document. Never do that with empty paragraphs. If you don’t enable View>Formatting marks, you’ll never be aware of these “noisy” paragraphs, notably at end of document.
  • when working with LO, save in native format. You’ll spare conversions when opening and closing the document. In case of sharing documents with M$ Office aficionados, send them in LO native format. Recent (10 years at least, this is not a novelty) M$ Office are supposed to read this format though they don"t follow the standard voluntarily. Put the blame on M$ and do your work conscientiously on your side.

Don’t hesitate to edit your question to provide more technical details if you encounter a more serious issue then mere excess blank lines at end.

Note: I erased the extra lines, saved in .doc and reopened. Removed lines weren’t back.

Please look at the screenshot I posted. I do have a problem with LO (it’s not just “more serious issue then mere excess blank lines at end”) and am looking for help, not sarcasm. The multiple CR’s are a result of my using a quick CR to lop off the extra blank page before I waste a sheet of paper when printing the doc – they are not part of the cause of the problem.

Perhaps the issue is LO version, but I’ve not seen sufficient evidence to warrant doing an “out of distribution” upgrade. But I’m open to hear any good reasons why I should.

Thanks

The solution was to move up to version 6.1.5.

Thanks to those who helped.

Joe Henley