How to disable unnecessary "read-only" -question in Libreoffice 7.2?

(created my 1st LO account just because of this “feature”)
How do I turn OFF this totally unnecessary popup? It’s clearly not needed for normal home user, or at least you should be able to turn it OFF somehow! It simply slows down reading/browsing of documents.
Already switched back to 7.15 because of this :frowning:

What Operating System are you using? Also details like the exact error message are needed as we are users like you.

And what is the use case when this (btw: what exactly incl. message shown) happens? Your question isn’t a question providing any details. Are you telling that this happens every time you open a file? Would you like to express users you addressed your rant to are not “normal” users (whatever “normal” means in the context of using software)? Do you even know that this site is about users answering questions of other users of LibreOffice? We are really sorry that something forced you to open an LibreOffice account.

References
Bug report: tdf#143971
Question: Is there a way to remove new LO 7.2 read only popup notification?

A third-digit-zero version shouldn’t be expected to be “perfect”. There are still bugs that need be fixed.

Why so aggressive reply?
I’ve been using Libreoffice since around 2012 after Openoffice. Currently w/ W10Pro and modern HW. Issue is same as you linked, unnecessary popup every time when I open any LO file with LO 7.2. Just want to know how I can turn this new feature off?

Maybe because you are not giving the details needed. Also if you are trying to read directly from an email attachment there is no way as far as I know. The best solution is save the attachment to your desktop and then open it.

I honestly didn’t know I should be so specific with my question :frowning:
All local storage and reading from local drive. Distraction/problem with LO 7.2 is that popup-window. Earlier Libreoffice-versions like LO 7.15 gave just minor mention-bar above document (“This document is open in read-only mode.”) and that’s ok.
Obviously this popup with LO 7.2 was triggered by read-only attribute, because we do set those just in case. Another way to prevent accidental removal of any files, because I’m not the only user of these files. But LO 7.2 shows popup and that is not necessary at all :frowning:

Two possibilities there 1 is someone else has it open at the same time you do which would mean you get that. The second possibility would be that it was open when you had a power failure of some kind and need to delete the~.lock file.

You are all missing the point. This is a simple functionality and usability issue and I am also feelings OPs pain on this.

With MS Office if you open a file, any file anywhere, and that file is read only or open and locked from editing by someone else, the file just opens and displays the read only status on the title bar. It does not pop up a window or display a dialogue box requiring a click to open the file read only or to create a copy.

This is annoying, unnecessary, confusing, and negatively affects user experience for no perceptible reason.

It is also not clear at this point if this is a bug or a feature. If it is a feature, a method to disable it would be most appreciated. If it is a bug, a fix is desired.

@L3n4rd you describe a different problem. Why didn’t you create your own question?
You don’t give your OS nor your LO version, how is anyone to answer?
If you have Windows 10, I suggest you read Installed 7.1 yesterday; today MS Office is non-op. Cheers, Al

On the contrary, my problem and OPs are the same. We want to disable the pop up box that asks you if you want to open a file read only or create a copy and we see no way to do that via software settings.

I appreciate the response, but the issue you link to does not appear to have any relevance to the issue described here. I have added the exclusions in the AV with no effect.

If all documents in one folder / directory open read-only then it’s most likely something on operating system / file system level setting every document to read-only permissions.

Sorry, I misread. I thought you said it did not display any pop-up; it seems you were talking about MS Office.
Cheers, Al

Opening Read Only for all files sounds like your anti-virus’ anti-ransomware blocking changes. It doesn’t sound like Windows Defender, maybe AVG or Avast. Have a look at my answer to Installed 7.1 yesterday; today MS Office is non-op

Usage of W10Pro mentioned 3wks ago, see earlier message “Currently w/ W10Pro and modern HW.”
This popup has nothing to do with antivirus, its from LO. Most definitely a new feature but why, because that earlier bar mentioning “Read-only etc” was ok. Now LO always opens popup in the middle of the screen when file is read-only. Meaning addional clicking even if you are just opening document for reading. When just browsing several documents in a row it gets annoying very quickly, no such problem with LO 7.15. If I only could turn this new feature off in settings, that would be fine.
And yes, this is my first real problem with LO ever (since 2012), happily only usability issue but still a problem.