How to fix LibreOffice 6 crash loop on Mac OS X High Sierra 10.13.3?

When starting LibreOffice 6 (6.0.3) it crashes.

I did delete the whole LibeOffice and folders in Library/ApplicationSupport but it did not fix the issue.

Everytime I start LibreOffice 6.0.3 it crashes, but after pressing “open again” (1-x times) it starts.

When installing the language pack it did not find LibreOffice automatically and did also crash, but did install at second try.


I tried the following:

- delete ~/Library/ApplicationSupport/LibreOffice
- disable Java
- disable OpenGL
- disable OpenCL
- delete .bash_rc and .bash_profile

None of these did help.

Running the soffice executable directly from Finder or the Terminal works fine.
I tried with a new user profile and there it works fine, also.

So it is definitely not a general issue but older versions of LibreOffice like 5.4.4 do work fine with my user profile in question, so it must be something special with the way how LibreOffice 6 starts.

Launch LibreOffice 6 and turn off OpenCL: Preferences > LibreOffice > OpenCL: deselect all options.

See this bug.

Deactivating all OpenCL options did not help, please see my update above.