How to format endnotes in a chapter with title

Hi! This question is related to this one: Heading for endnotes page
What happens when I did that trick is a text aligned to bottom. Thought I will have to collect the endnotes elsewhere or need another hack to make it work…
The goal is a list of references at the end of the text in a chapter called “References”. So it has to flow from top to bottom. Any ideas?

Edit: Using LibreOffice in macOS Mojave 10.14.6, saving in ODT. The notes are inserted as endnotes, and there is also cross-references. But when I did the procedure following the instructions of the link, the endnotes were collected in a footnote at the end of the last section.

Edit 2: Some screenshots. This one shows that the spacing is incorrect, I defined the footnote area to use all page. This is ease to solve with some enters, but I would like some logical way. The following image will show that the text is vertically aligned to bottom. Maybe with some enters I can push the text up, but again I would like a better solution (enter to align is barbaric to me).
image description

Edit 3: A sample of the file: Exemple of Endnotes Issue.odt

Edit (don’t use an answer) your question for:

  • OS name and LO version
  • format used to save the document (.odt or .doc(x))
  • have you inserted your notes as endnotes or footnotes (just to make sure because you say thet are aligned to bottom)?

If this is a list of references, wouldn’t a bibliography be a better option?

Please attach a short sample file for analysis. To attach, edit again your question and use the paperclip tool. In case there is sensitive data, replace it with “lorem ipsum”.

Screenshots are fine to describe a problem but don’t allow to diagnose precisely what’s going on. This is why I request a sample file (make it short, please, 2-3 pages max).

Your references really look like a bibliography. Unless you insist on keeping the references in document order (instead of alphabetic order of some key you choose yourself – it may be numeric but usually it is [Polanczyk2005] or [Polan2005], [GBD] or similar), why wouldn’t you give a try to Bibliography?

Endnotes are known to exhibit various problems such as yours because they are formatted in a section of their own (unless configured otherwise) which is the very last object in the document. Bibliography is more versatile.

This is a work of another person I am given a hand, also I would like to dominate LO. Not a good idea to share it here… Maybe a bibliography was a better idea, but the text is ready with all references liked to text where there is a citation. I just wish to format the list as it is, numbered, and keep the link. Maybe there isn’t a way to do it…

There sure is a way to do it, but the problem must be diagnosed first. A 1- or 2-page sample shouldn’t disclose any private intellectual property. Please extract it (eventually replace text with garbage) and attach the file.

Now there is a file. I just deleted most part of the text, not important the amount, but the quality, right… Thought I am attempting to make a numerated bibliography, but I don’t know how to change endnotes to bibliography.

From quick examination, your document is plagued with direct formatting which prevents from playing with the Endnote paragraph style (changing it does not reformat all notes!, thus I can’t see the changes in “vertical alignment”). Though I think I have usual top alignment (LO

You inadequately use sections (e.g. there’s no point in designing the cover page in a section and using empty paragraphs to space). A section is meant to have a different number of columns than the current page for a limited inline extent or to group endnotes with a part of document. In your case, your section nesting is strange: Referências is strictly equal to Texto. Also why is Texto included in Corpo instead of being one by itself?

I don’t understand why you defined a bookmark for each note anchor. To insert a reference to an existing note, Insert>Cross-reference, Cross-references tab, Endnotes Type.

You incorrectly use Default Style instead of Text Body.

to be cont.

All in all, your document is badly styled. Why have you created a Default paragraph style (not linked to Default Style!) with 2 siblings? You lose the possibility to adjust it from Default Style. You messed the para style hierarchy by removing some of them from the built-in one. Thus, the defaults in Tools>Options, LO Writer>Basic Fonts are no longer forwarded to them.

You messed the character styles by creating a hierarchy (unless this is wilfully intentional) under Default paragraph font. This new style will hide what you defined in the paragraph style. If you meant the default font from the paragraph, this is done with character style Default style (which is a reset to paragraph attributes). Worst, in the sample, no character style is used!

I don’t know what your Listlabel99 are for, I hope this is for numbered list but I could not find them in the list paragraph style definitions.

(to be cont.)

As a result, it is impossible to format your document only playing with styles because it is not consistently and rigorously styled with superimposed direct formatting.

From the sample, it is clear that the bibliography tool would definitely be the right tool for your purpose.

Unfortunately, there is no automatic procedure to change from endnotes to bibliography. The first reason is you must create the bibliographical references (which go into an internal database). The bibliography tool is very powerful and versatile. You’ll need some time to master it. So if you have a deadline, it’s up to you to decide for a tedious and difficult editing in the present state or for some time dedicated to learning and reviewing your document with a strict and consistent method.

Did I do something right? Ok, the document was converted from docx and there was a lot of problems already. The author did some mess and the conversation processes created a lot of new ones. Each page was with it’s own section, for start, I had to deleted one by one, there is no way to delete more than one style. Those styles was imported from another docx already formatted by the rules. In Brazil, everybody split the document into several sections, is the only way to make it according to local rules (ABNT). Anyway, thank you for your efforts, you should have made an answer, sometimes the answer is like this - you can’t. But I am very well impressed with this Libre Office version. The logic is different than Word but it’s better, I will have to learn it. Right now I will make the best solution for my client, next time I will start from better practices.

The different founding principles between M$ Word and LO Writer are the causes for many style mess. You should have mentioned that it was converted from Word. Word has no notion of styles beyond paragraph styles and forces user into direct formatting. Also sections in Word are difficult to equivalence in Writer: they usually correspond to page style usage but exceptionally they should be translated into sections.

Compatibility is very difficult to achieve. Easy for a simple document (a 1-page letter) but nearly impossible at 100% reliability for sophisticated elaborated documents such as yours. This means after conversion the document should be thoroughly reviewed to be styled in Writer way, i.e. mainly create and use character style and reorganise the page styles.

I think ABNT is easy to implement as a set of styles (paragraph and page, eventually character) stored in a template. The hard point is to replace Word “section” by “page [style]” for Writer parlance.

Yes, I forgot to mention the conversion from Word. Also, as long LO Writer is very impressive, very solid application, some function are missing to make adjustments and cleaning deeply in large documents. I will take a look how to make some plug ins for this awesome…

some function are missing


When switching from Word to Writer, the key to success is to understand that Writer primary goal is not to format a document. Its primary goal is to markup semantically a text. The tags for that are called styles (and there are many more categories than in Word). You then assign visual attributes to styles (font face, size, weight, colour, margins, spacing, border, break, …). This is what common people call formatting. In Writer, “formatting” is a consequence of markup, not the other way round.

Whenever you use the bold, italic, … buttons, you create anonymous markup which is not controlled by style. This is the beginning of formatting hell. It prevents you from making consistent and “automatic” adjustments.

Since your document is heavily direct formatted, this may be the cause of your difficulty or shortcomings.

After ajlittoz’s long list of my mistakes (and he is right) I pick some idea here and there and could format the text as I need. The hack is to use the header configuration only for the area where the endnotes are, make sure the option to collect at the end of section is unchecked. Next, configure the header to different content to first page…

Now you put the page number field and the title as you need. Don’t forget tu put the page number in the next page because it will not follow the standard of the first page. Voilá, problem solved! Of course, try not to create this problem in first place…