How to get rid of an unwanted and automatic "cell protection" in Calc

Hi Libreoffice people,

I have the same issues today (Sep 16, 2020) as the old post below. I run version (64bit). I have been trying to find a solution for days and nothing. It is a very very frustrating bug. Any permanent solution or at least a fix?

Thank you for any answer. Hopefully it’s not going to be closed as “not relevant or outdated”. :slight_smile:

Posted on Sep 14, 2014. Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2016-03-03 17:58:13.438933.

"I have an ods file that I use to store translations

I have had a lot of problems with it over the years due to various bugs in Calc. One of those is that often times Calc will report that a cell is protected when I try to change a value (I never ever tried to protect the document, sheet or cell). In most cases, despite the annoying popup, it will actually change the value, a bug in itself, but in other cases it won’t allow me to change the value, which is worse, since I can’t turn it off.

When I go to format cell, it also reports that it can’t be formatted because it’s protected, but the protected checkbox is turned on. When I turn it off, I get the same message and when I get back to the Format Cells popup, it’s checked again.

Neither sheet or document is protected. I don’t want it, I don’t need it. How do I turn it off, rip it out, get rid of this bs?"

UPDATE: Here is the ods file:
Calc _ Unwanted automatic cell protection with bugs.ods

I am using W10, Home Edition, 64bit

Can you upload a problematic .ods file here to examine it?

Please edit your question to indicate which OS you are using as this might be relevant.

Question 39653 was closed because OP never replied to comment questions after two years.

@piiaa to reply to a question in the comments, you can comment, or add to your question. To add requested information relating to your question just click on the edit icon and add it at the bottom of your question. To add a file while you are in edit mode in your question just click the paperclip icon. Cheers, Al

Hi, thank you for the replies. I updated the question with the uploaded ods file where you can see the bugs.

It works now. Thanks Earnest AI.

Autocalculate seems to be turned off for the sheet, turn it back on (tick visible) Data > Calculate > AutoCalculate. Then Recalculate everything by pressing Data > Calculate > ReCalculate Hard or Ctrl+Shift+F9. Should be sweet after both steps have been done.

In a new spreadsheet the default state for a cell is to be protected; it doesn’t mean anything until the sheet is protected. Cheers, Al

It works now. Thanks Earnest AI.