How to get text on one page to go up to preceding page [SOLVED]

i’ve got a document which a friend gave to help him out with the formatting. It has each paragraph numbered. The problem is that on many pages where a new chapter begins, the chapter heading appears but the actual text of the chapter appears on the next page. How can i move the text up so that it starts just below the chapter heading?

Please stay safe and have a great evening! :slight_smile:contestacion_file_to_upload.odt

P.D. i think i’ve been able to upload - part - of the file. It’s a whole book and all we need is an “example” of the problem.

Have a beautiful evening and be happy! :slight_smile:

Read these guidelines and ask a good question. In particular: when you have problems with a particular file, share the file.

And don’t forget to mention if your formatting is done manually or with styles.

I’ve never seen such a mess with pages: you mix at least two sheet formats (Letter and a user one at least). I wonder how this can be printed.

Don’t build manually your TOC, even less in a table. If you structure consistently your headings with styles Header n, the TOC can be generated automatically without page number error when you edit your document.

Start by reading the Writer Guide.

Everything in your friend’s file is formatted “manually”, directly applied formats without using styles.

For their own sake, when making a large document like a whole book, learn about styles.

The reason for the text jump is that some paragraphs are marked “keep with next”. This works like a “magnet” to pull content down if you can’t fit everything on one page.

To resolve:

Note: The procedure below changes the entire document. You don’t want major upsets. Consider saving a backup first. Do not click on anything else, only what it says in the procedure, to remove the “offending” setting.

Note also: If you are running MacOS, the shortcut keys mentioned below will be cmd where the procedure says ctrl.

  • Select everything in your document (ctrl+A)
  • Select menu item Format - Paragraph ...
  • Select tab Text flow
  • See the checkbox at Keep with next.

    You should see it filled with a square block, signifying “settings vary through selected range”.

    Click it one or twice so it is empty (unticked).
  • OK


There is a lot of direct formatting in the sample, which will most likely hurt the finishing/publishing workflow (in particular if the book is submitted to others for publishing). If you decide to clean up and format from scratch (using styles) you need to remove all direct formatting first. With all content selected (like in the procedure above) you can press ctrl+M to remove direct formatting. All content will then have the same font shape and size, so headings may be difficult to spot.

To get started with styles

  • Pressing ctrl+1 will mark the current paragraph as a heading (shortcut key to apply the Heading 1 style).
  • To revert to text body, press ctrl+0.
  • If you don’t like the appearance (font face, size, bolding, space above/below) of heading and/or text body, edit the corresponding style instead of formatting directly.
  • Styles are found in the right side panel. Click the icon with overlapping AA. Right click an entry in the list to edit.

Please share this info with your friend.

Thank you keme. You are very kind. i’ve already had this printed once and it came out really beautiful esp. with the binding and all but when i got the book back we saw all the empty space - lol. FYI this book was “imported” into LO from one of the .doc or docx formats - so it’s not wonder it’s pretty messed up.

i had had this prob. before but was such a long time ago i wasn’t sure that it was even with LO. i was lucky to be able to figure out how to change all the roman numeral page numbers into regular ones.

Thanks for being so specifc and helpful. We’ll try the squishing pages first and then maybe just change table to text and manually place the page numbers in the TOC so as not to have to redo the whole doc.

Thanks again - have a radiant day and please stay safe! :slight_smile:

@frazelle09: on this board the correct procedure to “close a thread” is not by tagging the title as [Solved], but by “accepting” the answer, that means that you click in the gray checkmark to the left of the answer that solved your problem, in this case the one above. It will turn green when you hover the mouse over it, then click it. It will also award @Keme with some more karma.