How to insert emoji in plain-text (B&W) style?

I’d like to insert emojis in plain-text style, that is, in black & white without additional colours (or animations). I’m using fonts (such as DejaVu or Noto) that support them.

However, whenever I enter or paste one – even using “Paste unformatted text” – I get a coloured emoji. There seems to be an automatic substitution going on, but I can’t manage to find it and deactivate it in the options. Can someone help me with this? Thank you!

Which operating system and which LibreOffice version do you use?

Enter via the menu Insert>Special Characters.

Disable substitutions via the Tools>AutoCorrect Options... menu in the Options tab.

Can that help?

Thank you for the suggestions!

I’m on Windows 10 64bit, LibreOffice

“Insert>Special Characters” didn’t help. And substitutions were already disabled.

I discovered, however, that neither DejaVu or Noto include those BW emojis. So Impress was substituting some other fonts. I forced “Segoe Symbol” and now I can see them.

I think it’d be better if LibreOffice clearly indicated that a font has been substituted. If I select the symbol and check its font, what’s reported is the font I chose at first and not the one used for the substitution.

If Segoe Emoji is the only emoji font installed then it isn’t really a substitution.
I have EmojiOne font installed which delivers black and white emojis. I tried Noto Emoji-661A.ttf which comes out black and white on my Windows 10 (11 from today) computer but it looks awful and the text worse. A reason for the B&W rather than colour for Noto Emoji might be here: fonts - How do I replace Windows 10's emoji? - Super User

For whatever reason, possibly alphabetical, when I type :smile: in Writer I get the less intrusive EmojiOne font rather than Segoe Emoji. Cheers, Al


Great tip about EmojiOne, thank you!

The confusing “feature” is that LibreOffice seems to automatically choose another font for the glyph, if the glyph isn’t available in the current font, but does not report the actually used font in the Character Properties bar…