How to move columns/rows in LO3.5

We use OO/LO in our firm instead of MSO. recently I have updated my comuter to the newest LO 3.5 and a big problem occur:
It is not posible to move complete columns/rows in Calc just by selecting the column by clicking on the header and them drag/drop to a new place while holding Alt, Ctrl or Shift (depend on what we want to do).
This function works without problem in MSO, OO and older LO, but in the version 3.5.0 now there is probably a bug and instead of moving complete columns/rows it just move the data in the selected column/row (which is not the same!).

This functionality is one of the essential function and without it we have to stop using LO in our company.

We tried to solve this problem in the Czech BB formum, without success.

Can someone check the problem and confirm it or help us to learn how to move complete colums/rows?


Should be fixed in 3.5.2. Sounds like fdo#46230 which I fixed last night and which has still pending review for 3.5.2

If this is not the same problem please open a bug report ( ) with a test document and a detailed instruction.

Thanks for the answer. Yes that’s the bug.

This bug appears to have returned later in the v3.5 series (fdo#58440) and is reported as still (v4.1) not working.

I use Ubuntu 12.04 with unity and LibreOffice Build-ID: 350m1(Build:2)
I have still the problem that I can not drag&drop a collumn/row/cell.

If you’re trying what I think you’re trying for, then select a row, hold Shift+Alt and move the row with your mouse as you would with OO.

That makes no difference to dragging and dropping. The problem is that it overwrites a target row that contains text. Problem has never been addressed since first reports.

Hi, had the same problem with Ubuntu 12.04 & Unity & LibreOffice
Build ID: 350m1(Build:2). I couldn’t move columns, rows or cells.
The solution to this bug is simple. If you hold down the alt key and try to move the column/row/cell, it won’t work. Its important to press the mouse button first and then press the alt key.

Ubuntu 12.04/gnome-shell/Libreoffice

alt-mouse button doesn’t work for me. With gnome-shell I has a problem because by default alt-mouse is a window manager action. I disabled this (using dconf-tools if you’re interested) but I still can’t move rows around. I tried alt+“left button” and “left button”-alt (bleach46290’s suggestion). Still a bug perhaps?

For some reason I can’t reply to the “correct” answer. But it still doesn’t work for on ubuntu 12.04