How to remove noto fonts

I am running Ubuntu 18.04.02 with Libre Office. There are a lot of fonts I don’t want and I have been able to delete most of them, but Libre Office still shows me a list of fonts beginning with noto. Where are these stored and how do I remove them? They are not in /usr/share/fonts or /usr/local/share/fonts or ~/.local/share/fonts.


Did you install from repositories or from the official build? For version 6.2, for example, the official build install a lot of fonts on


that are only accessed by LibO.

In order to avoid duplicated fonts, dictionaries and libraries, it’s always a good idea to only use repositories from your distro and not the official builds.

Libre Office was installed from the live CD doing a full install. There is nothing in /opt.

I have no experience in ubuntu, so I don’t know how they build their packages, but try looking for something similar to /usr/lib64/libreoffice/share/fonts/truetype/. On my openSUSE Leap I only have opens___.ttf there.

To know where LibO is installed, open a terminal (like gnome terminal or konsole) and issue whereis libreoffice


on my current ubuntu 19.04 the fonts are in /usr/share/fonts/truetype/noto/
(Command sudo find / -name "*noto* is your friend).

  1. To get the package owning a special font use: sudo dpkg-query -S <full_path_of_font>
  2. To remove all noto font use: sudo dpkg --list |awk '/fonts-noto/{print $2}' | sudo xargs dpkg --remove

At least on my system, no Noto fonts visible in LibreOffice anymore.

Hope that helps

Thanks, using find showed lots of places where noto was used with some fonts being opentype too. In the end I installed the gnome font-manager (the real manager not the viewer). This found them all and I was able to easily uninstall them. Problem solved - many thanks.

Thanks, but I still have about 6-8 noto fonts in LibreOffice remaining. I restarted my system and I still have the 6-8 stragglers. Any suggestions?

I think you just want to disable the fonts, rather than remove them.

Noto in particular—at least on my distro, elementaryOS 6.1—is depended upon by a number of other important packages, possibly even large parts of the desktop environment.

For any font but Noto, I’d give the usual recommendation of unchecking the ones you don’t want to see with Font Manager.* However, Noto comprises hundreds of individual font files, and I don’t think Font Manager allows enabling/disabling of multiple fonts at once—at least not the version I have available in my distro’s standard repositories. So that’s a lot of clicking, and it’s another package that you’d have to install.

Anyway, all Font Manager does to disable fonts is drop an XML config file in in ~/.config/fontconfig/conf.d containing a bunch of <rejectfont> stanzas, so I wrote a Perl script to reproduce that config file for all fonts matching a given pattern. This config can be easily activated/deactivated if you need all the Noto fonts enabled at certain times.

See the GitHub gist for details.

*can’t link directly because I don’t have enough reputation, but search your package manager for it

1 Like

And this question shows what can happen when you remove fonts (Liberation in this case) that LibreOffice relies on Text cursor gone, can’t see what I type, and missing words from file

1 Like

Font Manager - a graphical user interface for previewing and managing fonts for GNOME and other environments.

I got the idea for the Perl script mentioned above by inspecting the changes made to the filesystem—specifically to ~/.config/fontconfig—when fonts are disabled using Font Manager’s GUI.