How to select JRE 7 on Mac OS X 10.9 for LO 4.1x?

I’m running LibreOffice on Mac OSX 10.9. I have java version “1.7.0_45” (the most recent as of Oct. 26 2013) from Oracle installed. Java is working fine (i.e., I can compile and run Java apps). In LO, if I select Preferences → Advanced and click on “Add…” to select a JRE, all selections result in the error message “The folder you selected does not contain a Java runtime environment. Please select a different folder.”

For example, I’ve tried


and so on. All result in the same error message.

Any tips on what LO is asking for and where to find it?

This is an earlier version of the same question, without any satisfactory resolution. From your question:

I have java version “1.7.0_45” (the most recent as of Oct. 26 2013) from Oracle installed.

Are you certain you are running the original Oracle version instead of the Apple-supplied variant? The answer here indicates there are differences in install location between the two e.g.,

Oracle: /Library/Java/JavaVirtualMachines/<JDK_version>/Contents

Apple: /System/Library/Java/JavaVirtualMachines/<JDK_version>/Contents

EDIT: Also note my answer here.

I didn’t see that previous question initially. As far as I know, Apple doesn’t supply Java anymore. If you install 10.9, there’s no Java unless you go to and download from there. LO gives the same error from any path involving Java, including the ones you list for “Oracle” above. I don’t have the path you list as “Apple”.

Hmmm. It does indeed appear that Apple is abandoning its own variant of Java in favour of the Oracle-supplied one, once again. There have evidently been other problems with the update Apple made in this respect. I’m not sure if that link helps (as it relates to Java 6 and the Safari plug-in). The situation of Java under Apple is starting to look ugly.

Note this answer from a developer.