How to set TOC spacing between the identifier and subsequent text?

In my over 100 page document, the spacing is messed up in the TOC. There is only one space between the level entry, eg. 1.1, and the actual text (title). The main solution I’ve read about is to add spaces in the structure view of the style; which I’ve done, up to five spaces, but it makes no difference. Adding a tab adds a zillion periods, etc. Is there another setting which I should check?

Thanks for your help.

I was not clear, based on your initial description, exactly where your particular problem lay. I thought it may have been an issue with spacing between the title of the entire table of contents (ToC) and the ToC entries themselves i.e., a line spacing issue. The comment below however indicates that the problem is with spacing between the outline numbering identifier (e.g., 1.1.1.) and the remaining text of each particular ToC entry i.e., character spacing). I will leave my initial response here as it may assist others, but will also try and address the actual problem.

Initial response (line spacing)

A generated ToC includes an optional title entry which uses the Contents Heading paragraph style. The first heading entry then uses the Contents 1 paragraph style; the next lower-level entry the Contents 2 paragraph style and so on. Space can be added beneath any particular entry by editing the corresponding paragraph style e.g.,

  1. Ensure the Styles & Formatting panel is displayed (press F11).
  2. Right-click on the Contents Heading paragraph style > Modify… > Indents & Spacing tab > in the Spacing section set the Below paragraph value to “18.0pt”.
  3. Click OK.

There should now be a blank line equivalent between the optional title entry and the first heading entry in the ToC.

2nd response (character spacing)

This is largely covered by the answer by @manj_k (refer comment below) however I also find that including additional characters (e.g., SPACE) in the manner indicated in that answer to be somewhat unsatisfactory. Instead, I generally:

  1. Right-click the ToC > Edit Index/Table > Entries tab > Structure section.
  2. Place the cursor in the E# field as indicated (delete any characters that may already have been entered in this field).
  3. Click the Tab stop button immediately beneath this field.
  4. This should result in a new T field entry being included between the E# and E fields:

ToC structure

Note that this needs to be done for each ToC Level.

In order for this Tab character to be effective though it is advisable to also set the indentation appropriately for the various Contents N paragraph styles used throughout the ToC. I generally work on an 18pt basis as this is easy to relate to font sizes and to calculate multiples and fractions that are aesthetically pleasing. By way of example, using Before text and First line indentation settings of: 36pt/-36pt (Contents 1), 54pt/-36pt (Contents 2), 72pt/-36pt (Contents 3), 90pt/-36pt (Contents 4), results in this display:

ToC indentation display

Related to Modification of contents style

Ok, my explanation didn’t work. :slight_smile: Thanks for trying. A single line in my TOC looks like this:
4.1.1 Safety Information…8

— what I would like is an extra space or two between “4.1.1” and “Safety Information” ; so it’s spacing within the line that I would like to improve.
I have the same issue is my List of Figures:
Figure 3.18 Copy Modes blah blah
… when the titles get long, it gets harder to really break out the title from the section or figure number.

Thanks for clarifying. I have updated my answer accordingly.