How to turn off direct formatting in Calc

Hi Guys:

Everytime I paste in some new string of text in a .csv file, Calc changes the font size to something really small. Then I have to go in andy clear direct formatting.

Is there a way to stop this from happening in the first place.


Hi TimG!

You could use Right Click → Paste Special… → Unformatted text every time you want to paste something in your spreadsheet.

If you want to set up a keyboard shortcut to make it easier, you can create a macro and assign a shortcut to it as described in this answer.

Keep in mind you will need to activate the Macro functionnality first, by going into Tools → Options → LibreOffice → General → Enable Macro Recordings (or Experimental features if not present)