I cannot open ANY Libre Office format (*.ODS) calc spread sheet but can open MS Office Excel (*.XLSX) files

Hello Hoping to find some help with this.
System Specs:
OS - Window 10
Edition Windows 10 Pro
Version 22H2
Installed on ‎30/‎11/‎2020
OS build 19045.4046
Experience Windows Feature Experience Pack 1000.19053.1000.0
Libre Office versions: 7.3.5 and 7.6.5 64 bit

3 days ago I went to open an inventory spread sheet with Calc as I have done for the past 4 years. After asking for my password nothing happened.
I traced the process with Task Manager and saw the Libre Office process start normally and then stop using any disk or cpu resources. The only thing I could do was cancel the processes either by closing the window with the task bar or ending the tasks with Task Manager.

I then uninstalled Libre Office 7.3.5 and downloaded and installed Liber Office 7.6.5. I still could not open any Calc spread sheets (ODS). I can open Writer documents.

Today I uninstalled Libre Office 7.6.5. Then removed all traces of the program from the C:\Program Files sub-directory and my User’s AppData\Roaming\ sub-directory. I reinstalled Libre Office 7.6.5 but still could not open any Libre Office spread sheets (ODS).

Out of curiosity I copied an MS Office Excel file from my wife’s PC and tired to open it, and it worked. I tried several other .xlsx files and they all work fine. But if I save the file in the ODS format, they will not open.

I have disabled the Hard Ware Acceleration (OpenGL, OpenCL) option but that did not work.

I need to be able to get to my ODS files since they are not in any other format.
Thank you for any assistance you can provide,

Welcome @BrockTaz,
Some ideas from the simplest to the most time consuming:

  • Reboot your PC (if not already done) to clean any shadow process.
  • I would check the size of the Calc files using Windows Explorer, just to be sure they are greater than 0. Then I would make a copy of these files (at least a few) and only work from these copies.
  • If you can still open a Writer file, then open it and from there open one of the copied Calc file, does it work?
  • If your computer has enough memory and disk space, you could install VirtualBox, a Linux version like Ubuntu and work from there.

Did you get any message from your anti virus?

Maybe you need to add LibreOffice (soffice.bin) to the Allowed list in your anti virus / anti ransomware software. Even if you use different anti virus software, see this page if you need to find soffice.bin, Defender Controlled folder access exception for LibreOffice - The Document Foundation Wiki

Hello Steph1 and thanks for the reply.
I tired your suggestions and found the Calc files all have valid sizes greater than 0.
I tired to open a copied calc file from Writer, but that did not work. Still went into a wait state and had to be ended via task manager. I’m not a Unix type so I will need to look into installing a virtual Unix/Linux type OS.

Hello EarnestAI,
I should have stated I checked into this several days ago when I first started having this issue. I use Norton 360 and soffice.bin was already and still is granted authority in my user profile data tree. My apologies.

I don’t know how clever Norton is. Windows Defender needs to have the new soffice.bin added for each upgrade.

Thanks. I’ll give that a try.

Hi EarnestAI,
Well I had no joy with Norton. I checked the logs and as last time there was no entry for anything to do with Libre Office or soffice.bin. I did check the firewall this time and cannot find any reference to soffice.bin in the program control list.

I did however make a rather interesting and puzzling discovery. I can open spread sheets in the ODS format IF I disconnect my lap top from the network. As long as I am not on the network (no WIFI connections and the ethernet cable disconnected) I can open modify and save spread sheets. As soon as I plug in the ethernet cable or connect to my WIFI router, I start having issues.

I have changed my internet gateway hard ware from an old cable modem to the COX Panoramic WIFI gateway recently. I am thinking it was just after that change I started having this issue. Do you think this could be the cause or is it just a coincidence?

Thanks for you help

If your new home network is not set as private or trusted network then Norton might regard it as public and block access for LibreOffice. You might need to change the status of your home network in Windows and Norton and/or allow LibreOffice internet access.

this thread might be useful, Unable to access files and folders both on the PC and my Win11 laptop | Norton Community

Yes. All 3 network connections (ehternet, 2.4ghz and 5ghz) are all listed as private in Windows 10 and Norton 360. Also after launching Libre Office, Norton added soffice.bin to the program control list and marked it allow.

Still puzzled as to why not only does Libre Office work without the network connection but it is actually several magnitudes faster than it has ever been.

I would be inclined to ask on Norton Community.

Hi all and EarnestAI

I thought I’d leave an update on this. I don’t know what happened to cause this or what happened to fix it. As stated above I had discovered that if the laptop was disconnected from the network, Calc worked fine.

So for a few days I just disconnected the ehternet cable and opened any spread sheets I needed reconnected the ehternet cable and worked on whatever project without any issues. A few days into this I forgot to disconnect the PC from the network and opened a Calc spread sheet without any issues.

That was 5 days ago and Calc has worked fine ever since.

Thanks again for your help

I have found the solution for my opening Calc files issue. But first, I should have mentioned that we have a network in our house with the printer on the wife’s desktop. Ever since her retirement her desktop and the printer are usually powered off most of the time, unless I need to print something. I apologize for not mentioning it before, but as the suspect always says to the inspectors/detectives, “I didn’t think it was relevant”.

The solution was over on another thread Calc Files Won’t Open. Response 9 given by mikekaganski worked like a charm. Also answered my question about the enhanced performance I saw with the network disconnected.

Thanks and have a great day